summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2024-01-30 15:54:14 -0500
committerSam James <sam@gentoo.org>2024-01-30 21:27:48 +0000
commit6a499659bc0cd104d9fa50c45b56fbdd905839ab (patch)
treebd31d49c449d48ca26a3887146e89085130df786 /net-dns
parentnet-dns/bind: increase test timeouts, skip one test on sparc (diff)
downloadgentoo-6a499659bc0cd104d9fa50c45b56fbdd905839ab.tar.gz
gentoo-6a499659bc0cd104d9fa50c45b56fbdd905839ab.tar.bz2
gentoo-6a499659bc0cd104d9fa50c45b56fbdd905839ab.zip
net-dns/bind-tools: increase test timeouts, skip one test on sparc
Closes: https://bugs.gentoo.org/852692 Bug: https://bugs.gentoo.org/908617 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Closes: https://github.com/gentoo/gentoo/pull/35106 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind-tools/bind-tools-9.16.41.ebuild9
-rw-r--r--net-dns/bind-tools/bind-tools-9.16.42.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/net-dns/bind-tools/bind-tools-9.16.41.ebuild b/net-dns/bind-tools/bind-tools-9.16.41.ebuild
index 69c405cfce33..53c11f114c95 100644
--- a/net-dns/bind-tools/bind-tools-9.16.41.ebuild
+++ b/net-dns/bind-tools/bind-tools-9.16.41.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -60,6 +60,13 @@ src_prepare() {
# toolchain, and it breaks further configure checks
sed -i -e '/LDFLAGS=/s/-zrelax=transtls//' configure.ac configure || die
+ # Slow tests
+ sed -i "s/{name='mem_test'}/{name='mem_test',timeout=900}/" "lib/isc/tests/Kyuafile" || die
+ sed -i "s/{name='timer_test'}/{name='timer_test',timeout=900}/" "lib/isc/tests/Kyuafile" || die
+
+ # Conditionally broken
+ use sparc && sed -i "/{name='netmgr_test'}/d" "lib/isc/tests/Kyuafile" || die
+
# bug #220361
rm aclocal.m4 || die
rm -rf libtool.m4/ || die
diff --git a/net-dns/bind-tools/bind-tools-9.16.42.ebuild b/net-dns/bind-tools/bind-tools-9.16.42.ebuild
index 69c405cfce33..53c11f114c95 100644
--- a/net-dns/bind-tools/bind-tools-9.16.42.ebuild
+++ b/net-dns/bind-tools/bind-tools-9.16.42.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -60,6 +60,13 @@ src_prepare() {
# toolchain, and it breaks further configure checks
sed -i -e '/LDFLAGS=/s/-zrelax=transtls//' configure.ac configure || die
+ # Slow tests
+ sed -i "s/{name='mem_test'}/{name='mem_test',timeout=900}/" "lib/isc/tests/Kyuafile" || die
+ sed -i "s/{name='timer_test'}/{name='timer_test',timeout=900}/" "lib/isc/tests/Kyuafile" || die
+
+ # Conditionally broken
+ use sparc && sed -i "/{name='netmgr_test'}/d" "lib/isc/tests/Kyuafile" || die
+
# bug #220361
rm aclocal.m4 || die
rm -rf libtool.m4/ || die