summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2024-09-08 00:42:43 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-09-14 11:57:38 +0200
commit8661e8c172986e7f7d9e055ca919cfa88fc23fea (patch)
tree30eedbf5d3130f3b0e842586577664f947ba7b8f /net-analyzer
parentnet-analyzer/openvas-scanner: add 23.9.0 (diff)
downloadgentoo-8661e8c172986e7f7d9e055ca919cfa88fc23fea.tar.gz
gentoo-8661e8c172986e7f7d9e055ca919cfa88fc23fea.tar.bz2
gentoo-8661e8c172986e7f7d9e055ca919cfa88fc23fea.zip
net-analyzer/python-gvm: add 24.8.0
Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38514 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/python-gvm/Manifest1
-rw-r--r--net-analyzer/python-gvm/python-gvm-24.8.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/python-gvm/Manifest b/net-analyzer/python-gvm/Manifest
index 635607a85a25..19bd131cb19e 100644
--- a/net-analyzer/python-gvm/Manifest
+++ b/net-analyzer/python-gvm/Manifest
@@ -1,2 +1,3 @@
DIST python-gvm-24.1.0.tar.gz 287497 BLAKE2B 049154d5a516c56885c06e2a83884736c9e4009e1e69a817e541f1317d4fe0cb886f98ed1572bcb55bcfdd40ed7da6639ba52cc89b113731f24d941de3f6195b SHA512 d70d3c654aefb6e5949e35f68fd1585c243988a41165c9fefb54c8fe6dd24694391553201a95558d3fd4a6e8c88783a1fc4d2205ce9ae1a7d2fc2dafdf19825b
DIST python-gvm-24.3.0.tar.gz 278134 BLAKE2B 0da2b7d33164f7db773b51d917755678639f58f63438c23fac95fc3ebeb0412e470ee834804d327b4b46b379672d8f3fd673e0cfdf93f7fc65fe31393a5f3509 SHA512 d6e9dcaf3e776309b18b11393049e2edd08884241a2d050806d9b82dcc91d12e2a121f532b311a83e8f9bf367694b41efe66a9a8eefbe1bfb7bb7453ce08715c
+DIST python-gvm-24.8.0.tar.gz 289907 BLAKE2B d7e5a962f4d714406595e6bc8c939b7526389613e78dd5bc5b641ef2dc17eb33e42c51798f2c280e1a7af5a65ae0fa6ac3d059e1243b5adcdb27ce900cbcfe6d SHA512 dbc3dee750299f6e39417a442551ffc82939073cf1c4fd46076dcf05f9c59c2568bf8fc075607b36950387e11b021eb75c542c022329ff8e7ac42293f8489db9
diff --git a/net-analyzer/python-gvm/python-gvm-24.8.0.ebuild b/net-analyzer/python-gvm/python-gvm-24.8.0.ebuild
new file mode 100644
index 000000000000..bd120077c062
--- /dev/null
+++ b/net-analyzer/python-gvm/python-gvm-24.8.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Greenbone Vulnerability Management Python Library"
+HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/python-gvm/"
+SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/lxml-4.5.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.1[${PYTHON_USEDEP}]
+ test? (
+ >=net-analyzer/pontos-22.7.2[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # drop connection tests
+ rm -r tests/connections || die
+}