summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-09-13 13:51:46 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-09-13 13:52:14 -0500
commit750b93048f54a65e626c40ae023240cdf3ba98e1 (patch)
treeba63c9ac22ed0b146efd4612bd538d759cc1eefb /net-analyzer
parentdev-libs/rocm-device-libs: remove unused patch (diff)
downloadgentoo-750b93048f54a65e626c40ae023240cdf3ba98e1.tar.gz
gentoo-750b93048f54a65e626c40ae023240cdf3ba98e1.tar.bz2
gentoo-750b93048f54a65e626c40ae023240cdf3ba98e1.zip
net-analyzer/icinga2: drop 2.13.7
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/icinga2/Manifest1
-rw-r--r--net-analyzer/icinga2/icinga2-2.13.7.ebuild145
2 files changed, 0 insertions, 146 deletions
diff --git a/net-analyzer/icinga2/Manifest b/net-analyzer/icinga2/Manifest
index 650cccf6a3c4..e2c4bdfd2f1e 100644
--- a/net-analyzer/icinga2/Manifest
+++ b/net-analyzer/icinga2/Manifest
@@ -1,3 +1,2 @@
-DIST icinga2-2.13.7.tar.gz 9667526 BLAKE2B 0c3e9736ac66bdcbb3f5d94cc132b3e7e49fdf472bfdbf6900651d72ee9dbea38a06fc9df7c2a266f183b11132391d8174f6d5bd5c5045c4566fb8c3fb28bab9 SHA512 233b8c712b6c36e4d9e970213fac30b65ce72a3e078bbd900c3262c2b7f2b9cf3c1e606d2deb0a60bbb5d5bd3ea1be42bb884b91fc5a9801f4d774ffa1167357
DIST icinga2-2.13.8.tar.gz 9674265 BLAKE2B 8eebd3cd837bd6d03e9dc1060ef087bfc40c75be372a4d0f4da64d553c95e77c47a507202403249154f5b5f3f8a16c4be33cfa0eba555eb445d0892e15db736a SHA512 c16ee7d4876a712da19aaf8c2e85093bd3a4e60bdb29471a33d1e5df3df43c0e9b3afab59f5bbf2b99d06f6c501d52a2759a4b7783f877f3a5c713f43fe683a5
DIST icinga2-2.14.0.tar.gz 9389972 BLAKE2B f68d22e1494e9d835fe831e17863ace787b7bfc77c1b2aa9c9c4694e9fffbb5d54676bb2ce9c697d05f1b1e8557e8dd719723faac22fcb7eff2d4f1ee1e76f39 SHA512 5d0094f0b49cfcbb6f335f5fd6a9fd228bbbf4693f3c51f8664fcb5c2507b22fc1dbeaeed71c54a42c1305638b70865b7063e730c9eff7689873e0f2a6cc0285
diff --git a/net-analyzer/icinga2/icinga2-2.13.7.ebuild b/net-analyzer/icinga2/icinga2-2.13.7.ebuild
deleted file mode 100644
index 9c5f5a356fe9..000000000000
--- a/net-analyzer/icinga2/icinga2-2.13.7.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake systemd
-
-if [[ ${PV} != 9999 ]]; then
- SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 x86"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"
-fi
-
-DESCRIPTION="Distributed, general purpose, network monitoring engine"
-HOMEPAGE="https://icinga.com/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="console jumbo-build lto mail mariadb minimal +mysql nano-syntax +plugins postgres systemd +vim-syntax"
-
-# Add accounts to DEPEND because of fowners in src_install
-DEPEND="
- dev-libs/openssl:0=
- dev-libs/boost:=[context]
- console? ( dev-libs/libedit )
- mariadb? ( dev-db/mariadb-connector-c:= )
- mysql? ( dev-db/mysql-connector-c:= )
- postgres? ( dev-db/postgresql:= )
- dev-libs/yajl:=
- acct-user/icinga
- acct-group/icinga
- acct-group/icingacmd"
-BDEPEND="
- sys-devel/bison
- >=sys-devel/flex-2.5.35"
-RDEPEND="
- ${DEPEND}
- plugins? ( || (
- net-analyzer/monitoring-plugins
- net-analyzer/nagios-plugins
- ) )
- mail? ( virtual/mailx )
- acct-group/nagios"
-
-REQUIRED_USE="!minimal? ( || ( mariadb mysql postgres ) )"
-
-src_configure() {
- local mycmakeargs=(
- -DICINGA2_UNITY_BUILD=$(usex jumbo-build)
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
- -DICINGA2_PLUGINDIR="/usr/$(get_libdir)/nagios/plugins"
- -DICINGA2_USER=icinga
- -DICINGA2_GROUP=icingacmd
- -DICINGA2_COMMAND_GROUP=icingacmd
- -DICINGA2_RUNDIR=/run
- -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=ON
- -DUSE_SYSTEMD=$(usex systemd)
- -DLOGROTATE_HAS_SU=ON
- -DICINGA2_LTO_BUILD=$(usex lto)
- )
- # default to off if minimal, allow the flags to be set otherwise
- if use minimal; then
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=OFF
- -DICINGA2_WITH_PGSQL=OFF
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=$(usex postgres)
- -DICINGA2_WITH_MYSQL=$(usex mysql yes $(usex mariadb))
- )
- fi
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- newinitd "${FILESDIR}"/icinga2.initd-3 icinga2
-
- if use mysql || use mariadb; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
- fi
- if use postgres; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/*
- fi
-
- keepdir /etc/icinga2
- keepdir /var/lib/icinga2/api/zones
- keepdir /var/lib/icinga2/api/repository
- keepdir /var/lib/icinga2/api/log
- keepdir /var/spool/icinga2/perfdata
-
- rm -r "${D}/run" || die "failed to remove /run"
- rm -r "${D}/var/cache" || die "failed to remove /var/cache"
-
- fowners -R icinga:icinga /etc/icinga2
- fperms 0750 /etc/icinga2
- fowners icinga:icinga /var/lib/icinga2
- fowners -R icinga:icingacmd /var/lib/icinga2/api
- fowners -R icinga:icingacmd /var/lib/icinga2/certificate-requests
- fowners -R icinga:icingacmd /var/lib/icinga2/certs
- fowners icinga:icinga /var/spool/icinga2
- fowners icinga:icinga /var/spool/icinga2/perfdata
- fowners icinga:icingacmd /var/log/icinga2
-
- fperms ug+rwX,o-rwx /etc/icinga2
- fperms ug+rwX,o-rwx /var/lib/icinga2
- fperms ug+rwX,o-rwx /var/spool/icinga2
- fperms ug+rwX,o-rwx /var/log/icinga2
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano
- doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
- fi
-}
-
-pkg_postinst() {
- if [[ "${PV}" != 9999 ]]; then
- local v
- for v in ${REPLACING_VERSIONS}; do
- if ver_test "${PV}" -gt "${v}"; then
- elog "DB IDO schema upgrade may be required."
- elog "https://www.icinga.com/docs/icinga2/latest/doc/16-upgrading-icinga-2/"
- fi
- done
- fi
-}