summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-31 23:18:19 +0000
committerSam James <sam@gentoo.org>2022-12-31 23:23:21 +0000
commit0b8ee8b066590117a5ee11e2575d84b80427ef20 (patch)
tree59c29852fb4e0cd6588a209d39eb77d46254c733 /net-analyzer
parentdev-util/maturin: add 0.14.8 (diff)
downloadgentoo-0b8ee8b066590117a5ee11e2575d84b80427ef20.tar.gz
gentoo-0b8ee8b066590117a5ee11e2575d84b80427ef20.tar.bz2
gentoo-0b8ee8b066590117a5ee11e2575d84b80427ef20.zip
net-analyzer/pmacct: add 1.7.8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/pmacct/Manifest1
-rw-r--r--net-analyzer/pmacct/pmacct-1.7.8.ebuild112
-rw-r--r--net-analyzer/pmacct/pmacct-9999.ebuild3
3 files changed, 116 insertions, 0 deletions
diff --git a/net-analyzer/pmacct/Manifest b/net-analyzer/pmacct/Manifest
index 17b03eeb9f42..8c016cfe1dba 100644
--- a/net-analyzer/pmacct/Manifest
+++ b/net-analyzer/pmacct/Manifest
@@ -1 +1,2 @@
DIST pmacct-1.7.7.tar.gz 2149629 BLAKE2B 00357cbf1f52452c4a9ee9807e2c18f823019521cc9cb99553fe262826d7343e286694d666c7bab59e62767598ff373b3abafbecfdd43a823ba8784777740643 SHA512 7bc4c48041f023b5cd7ba927722478b0008d751bdb679f44beb2b281f4b16cb0bafb211d0fb947516ca80f86082f1bce578973ec298f4947ffd9d063a44bd00b
+DIST pmacct-1.7.8.tar.gz 2175335 BLAKE2B 1b95d48c479d59f2d4a7654e870e6f61c984c57c31aebbfb9fbf86f2d1027cde6a0f334489f33186bbb19ee7bdf94726f0053faa4829273de2d1975f58dff97f SHA512 df576644688ddb1957aa1583b101b96d86ab404c1416e0709b1bc85d691d13841bdb92a37a4526bc9273101dd11e3134d2fb35c06d2cbcde8e5bf7e84751a1c2
diff --git a/net-analyzer/pmacct/pmacct-1.7.8.ebuild b/net-analyzer/pmacct/pmacct-1.7.8.ebuild
new file mode 100644
index 000000000000..716720824619
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-1.7.8.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs systemd
+
+DESCRIPTION="A network tool to gather IP traffic information"
+HOMEPAGE="http://www.pmacct.net/"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pmacct/pmacct"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/pmacct/pmacct/releases/download/v${PV}/${P}.tar.gz
+ http://www.pmacct.net/${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="+bgp-bins +bmp-bins geoip geoipv2 jansson kafka +l2 mysql ndpi nflog postgres rabbitmq sqlite +st-bins +traffic-bins zmq"
+
+REQUIRED_USE="
+ ?? ( geoip geoipv2 )
+ kafka? ( jansson )
+ rabbitmq? ( jansson )
+"
+
+RDEPEND="dev-libs/libcdada
+ net-libs/libpcap
+ geoip? ( dev-libs/geoip )
+ geoipv2? ( dev-libs/libmaxminddb )
+ jansson? ( dev-libs/jansson:= )
+ kafka? ( dev-libs/librdkafka )
+ mysql? (
+ dev-db/mysql-connector-c:0=
+ sys-process/numactl
+ )
+ ndpi? ( >=net-libs/nDPI-3.2:= )
+ nflog? ( net-libs/libnetfilter_log )
+ postgres? ( dev-db/postgresql:* )
+ rabbitmq? ( net-libs/rabbitmq-c )
+ sqlite? ( =dev-db/sqlite-3* )
+ zmq? ( >=net-libs/zeromq-4.2.0:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.7.4--Werror.patch"
+ "${FILESDIR}/${PN}-1.7.6-nogit.patch"
+)
+
+DOCS=(
+ CONFIG-KEYS ChangeLog FAQS QUICKSTART UPGRADE
+ docs/INTERNALS docs/PLUGINS docs/SIGNALS
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC AR RANLIB
+
+ local myeconfargs=(
+ $(use_enable bgp-bins)
+ $(use_enable bmp-bins)
+ $(use_enable geoip)
+ $(use_enable geoipv2)
+ $(use_enable jansson)
+ $(use_enable kafka)
+ $(use_enable l2)
+ $(use_enable mysql)
+ $(use_enable ndpi)
+ $(use_enable nflog)
+ $(use_enable postgres pgsql)
+ $(use_enable rabbitmq)
+ $(use_enable sqlite sqlite3)
+ $(use_enable st-bins)
+ $(use_enable traffic-bins)
+ $(use_enable zmq)
+
+ --without-external-deps
+ --disable-ebpf
+ --disable-debug
+ --disable-mongodb
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ local dirname
+ for dirname in examples sql telemetry; do
+ docinto ${dirname}
+ dodoc -r ${dirname}/*
+ done
+
+ newinitd "${FILESDIR}"/pmacctd-init.d pmacctd
+ newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd
+
+ systemd_dounit "${FILESDIR}"/{nfacctd,pmacctd,sfacctd}.service
+
+ insinto /etc/pmacctd
+ newins examples/pmacctd-imt.conf.example pmacctd.conf
+}
diff --git a/net-analyzer/pmacct/pmacct-9999.ebuild b/net-analyzer/pmacct/pmacct-9999.ebuild
index 55db903b6abd..716720824619 100644
--- a/net-analyzer/pmacct/pmacct-9999.ebuild
+++ b/net-analyzer/pmacct/pmacct-9999.ebuild
@@ -7,6 +7,7 @@ inherit autotools toolchain-funcs systemd
DESCRIPTION="A network tool to gather IP traffic information"
HOMEPAGE="http://www.pmacct.net/"
+
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/pmacct/pmacct"
inherit git-r3
@@ -84,6 +85,7 @@ src_configure() {
$(use_enable zmq)
--without-external-deps
+ --disable-ebpf
--disable-debug
--disable-mongodb
)
@@ -94,6 +96,7 @@ src_configure() {
src_install() {
default
+ local dirname
for dirname in examples sql telemetry; do
docinto ${dirname}
dodoc -r ${dirname}/*