summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-09-06 11:16:04 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-06 11:16:04 +0200
commitc3c4c1e1ee4df63e23f0a1596dd883d734536a99 (patch)
tree1e7c34e1de9221cd52653d08503501170c4b006d /net-analyzer/rrdtool
parentdev-python/leechcorepyc: Stabilize 2.12.0 amd64, #868672 (diff)
downloadgentoo-c3c4c1e1ee4df63e23f0a1596dd883d734536a99.tar.gz
gentoo-c3c4c1e1ee4df63e23f0a1596dd883d734536a99.tar.bz2
gentoo-c3c4c1e1ee4df63e23f0a1596dd883d734536a99.zip
net-analyzer/rrdtool: quote emake arguments for lua's CFLAGS
Closes: https://bugs.gentoo.org/868675 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.8.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-analyzer/rrdtool/rrdtool-1.8.0.ebuild b/net-analyzer/rrdtool/rrdtool-1.8.0.ebuild
index ad96cbb55058..9d56454bf1fe 100644
--- a/net-analyzer/rrdtool/rrdtool-1.8.0.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.8.0.ebuild
@@ -159,13 +159,13 @@ lua_src_compile() {
# We do need the CMOD-dir path here, otherwise libtool complains.
# Use the real one (i.e. not within ${ED}) just in case.
local myemakeargs=(
- LUA_CFLAGS=$(lua_get_CFLAGS)
+ LUA_CFLAGS="$(lua_get_CFLAGS)"
LUA_INSTALL_CMOD="$(lua_get_cmod_dir)"
)
emake "${myemakeargs[@]}"
- popd
+ popd || die
}
python_compile() {