summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-12-19 13:19:32 +0000
committerMarek Szuba <marecki@gentoo.org>2019-12-19 15:17:05 +0000
commite8070f9b7d9965872c9d06e1a87701060dea244e (patch)
tree2fcc8b94b846e61c65184bff352e92d76867d203 /net-analyzer/nessus-agent-bin
parentnet-im/signal-desktop-bin: remove old version (diff)
downloadgentoo-e8070f9b7d9965872c9d06e1a87701060dea244e.tar.gz
gentoo-e8070f9b7d9965872c9d06e1a87701060dea244e.tar.bz2
gentoo-e8070f9b7d9965872c9d06e1a87701060dea244e.zip
net-analyzer/nessus-agent-bin: bump to 7.5.0
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-analyzer/nessus-agent-bin')
-rw-r--r--net-analyzer/nessus-agent-bin/Manifest1
-rw-r--r--net-analyzer/nessus-agent-bin/nessus-agent-bin-7.5.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-analyzer/nessus-agent-bin/Manifest b/net-analyzer/nessus-agent-bin/Manifest
index ef96c3ce18ca..5961ec0f2cd7 100644
--- a/net-analyzer/nessus-agent-bin/Manifest
+++ b/net-analyzer/nessus-agent-bin/Manifest
@@ -1 +1,2 @@
DIST NessusAgent-7.4.2-es7.x86_64.rpm 15989044 BLAKE2B 7fdc998acc4a5ee38519a3cf4d41d1de29cb8ddacb05bd6f734a458c63d7ce22c547b4d080320631d489dc381c4553d99a81786dcb48231833a77561ffa6928f SHA512 4aacc51d360c41963ad46c0976322cd29012d52e054337d4e0a303257796923bd35059324a041827ce0c54ef5c5dd6738311fcc4f0bcba19b6d4ea1e3730a146
+DIST NessusAgent-7.5.0-es7.x86_64.rpm 16793328 BLAKE2B 2a7409477f0d08d2be6d3c5e482f33e73861bc01c3c26e1edd689d71861621f5699ce0e2bb67e994dcd54e9e1314dee056b46aea79fe990bf1629e229ada8e64 SHA512 ed82b37d67a27a3fc9d317a9009afd42332b2935f869f72344f60946a28446ee606821b927f74a4899bb3c5d485b1a607935714ab604e206108db3abe99dcc38
diff --git a/net-analyzer/nessus-agent-bin/nessus-agent-bin-7.5.0.ebuild b/net-analyzer/nessus-agent-bin/nessus-agent-bin-7.5.0.ebuild
new file mode 100644
index 000000000000..20d896ea6290
--- /dev/null
+++ b/net-analyzer/nessus-agent-bin/nessus-agent-bin-7.5.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rpm pax-utils systemd
+
+MY_P="NessusAgent-${PV}-es7"
+
+DESCRIPTION="A remote security scanner for Linux - agent component"
+HOMEPAGE="https://www.tenable.com/"
+SRC_URI="${MY_P}.x86_64.rpm"
+
+LICENSE="GPL-2 Nessus-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="mirror fetch strip"
+
+QA_PREBUILT="opt/nessus_agent/bin/nasl
+ opt/nessus_agent/bin/nessus-mkrand
+ opt/nessus_agent/lib/nessus/libjemalloc.so.${PV}
+ opt/nessus_agent/lib/nessus/libnessus-glibc-fix.so
+ opt/nessus_agent/lib/nessus/plugins/ovaldi64-rhel7.inc
+ opt/nessus_agent/sbin/nessus-check-signature
+ opt/nessus_agent/sbin/nessus-service
+ opt/nessus_agent/sbin/nessuscli
+ opt/nessus_agent/sbin/nessusd"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please download ${A} from ${HOMEPAGE}downloads/nessus-agents"
+ einfo "The archive should then be placed into your DISTDIR directory."
+}
+
+src_install() {
+ # Using doins -r would strip executable bits from all binaries
+ cp -pPR "${S}"/opt "${D}"/ || die "Failed to copy files"
+
+ pax-mark m "${D}"/opt/nessus_agent/sbin/nessusd
+
+ # Make sure these originally empty directories do not vanish,
+ # Nessus will not run properly without them
+ keepdir /opt/nessus_agent/com/nessus/CA
+ keepdir /opt/nessus_agent/etc/nessus
+ keepdir /opt/nessus_agent/var/nessus/logs
+ keepdir /opt/nessus_agent/var/nessus/tmp
+ keepdir /opt/nessus_agent/var/nessus/users
+
+ newinitd "${FILESDIR}"/nessusagent.initd nessusagent
+ systemd_dounit usr/lib/systemd/system/nessusagent.service
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "In order to link the agent to Tenable.io or an instance of Nessus Manager,"
+ elog "obtain an appropriate linking key and run"
+ elog ""
+ elog " /opt/nessus_agent/sbin/nessuscli agent link --key=<key> --host=<host> --port=<port> [optional parameters]"
+ elog ""
+ elog "This can be done before the agent is started."
+ fi
+}