summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-08-06 06:57:33 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-08-06 06:57:33 -0400
commit290e6570bb56bfc6dfeb0a1c52976a714094a877 (patch)
tree5220e1535aedee1470373236cb0689cba825cc0d /net-analyzer/2ping/2ping-4.1.ebuild
parentapp-dicts/wordnet: updated metadata to reflect updated bugzilla email (diff)
downloadgentoo-290e6570bb56bfc6dfeb0a1c52976a714094a877.tar.gz
gentoo-290e6570bb56bfc6dfeb0a1c52976a714094a877.tar.bz2
gentoo-290e6570bb56bfc6dfeb0a1c52976a714094a877.zip
net-analyzer/2ping: version bump to 4.1
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'net-analyzer/2ping/2ping-4.1.ebuild')
-rw-r--r--net-analyzer/2ping/2ping-4.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/2ping/2ping-4.1.ebuild b/net-analyzer/2ping/2ping-4.1.ebuild
new file mode 100644
index 000000000000..d97873a18ea0
--- /dev/null
+++ b/net-analyzer/2ping/2ping-4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A bi-directional ping utility"
+HOMEPAGE="http://www.finnie.org/software/2ping/"
+SRC_URI="http://www.finnie.org/software/2ping/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="server"
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/2ping.1
+ dodoc doc/{2ping-protocol-examples.py,2ping-protocol.md}
+ use server && {
+ doinitd "${FILESDIR}"/2pingd
+ newconfd "${FILESDIR}"/2pingd.conf 2pingd
+ }
+}