summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-10-01 19:56:04 -0400
committerAlexis Ballier <aballier@gentoo.org>2017-10-04 10:01:43 +0200
commit94d0465a437d2bc1e54a7e93da4b1b6eda354d31 (patch)
treea90c35bbc1db1a4b388b83f4a02f09076fb01dff /media-video
parentmedia-video/avidemux: Fix missing QT5 binaries (diff)
downloadgentoo-94d0465a437d2bc1e54a7e93da4b1b6eda354d31.tar.gz
gentoo-94d0465a437d2bc1e54a7e93da4b1b6eda354d31.tar.bz2
gentoo-94d0465a437d2bc1e54a7e93da4b1b6eda354d31.zip
media-video/avidemux: Fix building with GCC-5
Force -std=c++14 since the build uses a header with 'nullptr' which is invalid in GCC-5's default -std=c++98 dialect. Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'media-video')
-rw-r--r--media-video/avidemux/avidemux-2.6.20.ebuild4
-rw-r--r--media-video/avidemux/avidemux-9999.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/media-video/avidemux/avidemux-2.6.20.ebuild b/media-video/avidemux/avidemux-2.6.20.ebuild
index 5227e4fdf241..72ad632f6969 100644
--- a/media-video/avidemux/avidemux-2.6.20.ebuild
+++ b/media-video/avidemux/avidemux-2.6.20.ebuild
@@ -81,6 +81,10 @@ src_configure() {
# See bug 432322.
use x86 && replace-flags -O0 -O1
+ # The build relies on an avidemux-core header that uses 'nullptr'
+ # which is from >=C++11. Let's use the GCC-6 default C++ dialect.
+ append-cxxflags -std=c++14
+
local mycmakeargs=(
-DAVIDEMUX_SOURCE_DIR='${S}'
-DGETTEXT="$(usex nls)"
diff --git a/media-video/avidemux/avidemux-9999.ebuild b/media-video/avidemux/avidemux-9999.ebuild
index 5227e4fdf241..72ad632f6969 100644
--- a/media-video/avidemux/avidemux-9999.ebuild
+++ b/media-video/avidemux/avidemux-9999.ebuild
@@ -81,6 +81,10 @@ src_configure() {
# See bug 432322.
use x86 && replace-flags -O0 -O1
+ # The build relies on an avidemux-core header that uses 'nullptr'
+ # which is from >=C++11. Let's use the GCC-6 default C++ dialect.
+ append-cxxflags -std=c++14
+
local mycmakeargs=(
-DAVIDEMUX_SOURCE_DIR='${S}'
-DGETTEXT="$(usex nls)"