summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-03-23 20:44:15 +0100
committerJohannes Huber <johu@gentoo.org>2017-03-23 20:44:15 +0100
commitda6eb748fae73ffc816fd2beaf51be9d1ee24426 (patch)
treef886ee3edd0aec145b5276dc61247096031f3259 /media-video/ffmpegthumbnailer/files
parentmedia-video/ffmpegthumbnailer: Remove 2.0.8 (diff)
downloadgentoo-da6eb748fae73ffc816fd2beaf51be9d1ee24426.tar.gz
gentoo-da6eb748fae73ffc816fd2beaf51be9d1ee24426.tar.bz2
gentoo-da6eb748fae73ffc816fd2beaf51be9d1ee24426.zip
media-video/ffmpegthumbnailer: Remove 2.0.10
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-video/ffmpegthumbnailer/files')
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch23
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-ffmpeg29.patch62
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch47
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch46
4 files changed, 0 insertions, 178 deletions
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch
deleted file mode 100644
index 608494559217..000000000000
--- a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 9c2a5fe997a6d8b00bef49eabb7bc49840882ec6 Mon Sep 17 00:00:00 2001
-From: Dirk Vanden Boer <dirk.vdb@gmail.com>
-Date: Wed, 29 Apr 2015 20:19:58 +0200
-Subject: [PATCH] Fixed configuration summary
-
----
- .travis.yml | 1 +
- CMakeLists.txt | 2 +-
- 2 files changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 22803d9..6b6e515 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -239,7 +239,7 @@ ELSE ()
- MESSAGE(STATUS "register thumbnailer : disabled")
- ENDIF ()
-
--IF (ENABLE_UNITTEST)
-+IF (ENABLE_TESTS)
- MESSAGE(STATUS "unittests : enabled")
- ELSE ()
- MESSAGE(STATUS "unittests : disabled")
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-ffmpeg29.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-ffmpeg29.patch
deleted file mode 100644
index fb50ae85eb85..000000000000
--- a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-ffmpeg29.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-Index: ffmpegthumbnailer-2.0.10/libffmpegthumbnailer/moviedecoder.cpp
-===================================================================
---- ffmpegthumbnailer-2.0.10.orig/libffmpegthumbnailer/moviedecoder.cpp
-+++ ffmpegthumbnailer-2.0.10/libffmpegthumbnailer/moviedecoder.cpp
-@@ -266,7 +266,7 @@ bool MovieDecoder::decodeVideoPacket()
- return false;
- }
-
-- avcodec_get_frame_defaults(m_pFrame);
-+ av_frame_unref(m_pFrame);
-
- int frameFinished;
-
-@@ -312,14 +312,8 @@ bool MovieDecoder::getVideoPacket()
-
- void MovieDecoder::getScaledVideoFrame(int scaledSize, bool maintainAspectRatio, VideoFrame& videoFrame)
- {
-- if (m_pFrame->interlaced_frame)
-- {
-- avpicture_deinterlace((AVPicture*) m_pFrame, (AVPicture*) m_pFrame, m_pVideoCodecContext->pix_fmt,
-- m_pVideoCodecContext->width, m_pVideoCodecContext->height);
-- }
--
- int scaledWidth, scaledHeight;
-- convertAndScaleFrame(PIX_FMT_RGB24, scaledSize, maintainAspectRatio, scaledWidth, scaledHeight);
-+ convertAndScaleFrame(AV_PIX_FMT_RGB24, scaledSize, maintainAspectRatio, scaledWidth, scaledHeight);
-
- videoFrame.width = scaledWidth;
- videoFrame.height = scaledHeight;
-@@ -330,7 +324,7 @@ void MovieDecoder::getScaledVideoFrame(i
- memcpy((&(videoFrame.frameData.front())), m_pFrame->data[0], videoFrame.lineSize * videoFrame.height);
- }
-
--void MovieDecoder::convertAndScaleFrame(PixelFormat format, int scaledSize, bool maintainAspectRatio, int& scaledWidth, int& scaledHeight)
-+void MovieDecoder::convertAndScaleFrame(AVPixelFormat format, int scaledSize, bool maintainAspectRatio, int& scaledWidth, int& scaledHeight)
- {
- calculateDimensions(scaledSize, maintainAspectRatio, scaledWidth, scaledHeight);
-
-@@ -427,7 +421,7 @@ void MovieDecoder::calculateDimensions(i
- }
- }
-
--void MovieDecoder::createAVFrame(AVFrame** pAvFrame, uint8_t** pFrameBuffer, int width, int height, PixelFormat format)
-+void MovieDecoder::createAVFrame(AVFrame** pAvFrame, uint8_t** pFrameBuffer, int width, int height, AVPixelFormat format)
- {
- *pAvFrame = av_frame_alloc();
-
-Index: ffmpegthumbnailer-2.0.10/libffmpegthumbnailer/moviedecoder.h
-===================================================================
---- ffmpegthumbnailer-2.0.10.orig/libffmpegthumbnailer/moviedecoder.h
-+++ ffmpegthumbnailer-2.0.10/libffmpegthumbnailer/moviedecoder.h
-@@ -54,8 +54,8 @@ private:
-
- bool decodeVideoPacket();
- bool getVideoPacket();
-- void convertAndScaleFrame(PixelFormat format, int scaledSize, bool maintainAspectRatio, int& scaledWidth, int& scaledHeight);
-- void createAVFrame(AVFrame** pAvFrame, uint8_t** pFrameBuffer, int width, int height, PixelFormat format);
-+ void convertAndScaleFrame(AVPixelFormat format, int scaledSize, bool maintainAspectRatio, int& scaledWidth, int& scaledHeight);
-+ void createAVFrame(AVFrame** pAvFrame, uint8_t** pFrameBuffer, int width, int height, AVPixelFormat format);
- void calculateDimensions(int squareSize, bool maintainAspectRatio, int& destWidth, int& destHeight);
-
- private:
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch
deleted file mode 100644
index 33a96b85735d..000000000000
--- a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 621274d694dee1f8c92f5db99a5cff98e82c6bd4 Mon Sep 17 00:00:00 2001
-From: Dirk Vanden Boer <dirk.vdb@gmail.com>
-Date: Sat, 2 May 2015 09:33:34 +0200
-Subject: [PATCH] Use proper gnu installation dirs (Thanks to Vallimar)
-
----
- CMakeLists.txt | 15 ++++++++-------
- ChangeLog | 1 +
- 2 files changed, 9 insertions(+), 7 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 6b6e515..badb7cf 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -25,6 +25,7 @@ ENDIF ()
-
- PROJECT(${PACKAGE})
- INCLUDE(CPack)
-+INCLUDE(GNUInstallDirs)
-
- SET(CMAKE_EXPORT_COMPILE_COMMANDS 1)
- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
-@@ -189,17 +190,17 @@ ELSE ()
- ENDIF ()
-
- INSTALL(TARGETS ffmpegthumbnailer ${STATIC_LIB} ${SHARED_LIB}
-- LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib
-- RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX}/bin
-- ARCHIVE DESTINATION ${CMAKE_INSTALL_PREFIX}/lib
-- PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_PREFIX}/include/libffmpegthumbnailer
-+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/libffmpegthumbnailer
- )
-
--INSTALL(FILES man/ffmpegthumbnailer.1 DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1)
--INSTALL(FILES ${CMAKE_BINARY_DIR}/libffmpegthumbnailer.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
-+INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/man/ffmpegthumbnailer.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
-+INSTALL(FILES ${CMAKE_BINARY_DIR}/libffmpegthumbnailer.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-
- IF (ENABLE_THUMBNAILER)
-- INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dist/ffmpegthumbnailer.thumbnailer DESTINATION ${CMAKE_INSTALL_PREFIX}/share/thumbnailers)
-+ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dist/ffmpegthumbnailer.thumbnailer DESTINATION ${CMAKE_INSTALL_DATADIR}/thumbnailers)
- ENDIF ()
-
- CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/config.h.in ${CMAKE_BINARY_DIR}/config.h)
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch
deleted file mode 100644
index b1a198a93a1e..000000000000
--- a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 718f1b1147fe7e9138e2d503ed151e589d643772 Mon Sep 17 00:00:00 2001
-From: Dirk Vanden Boer <dirk.vdb@gmail.com>
-Date: Sat, 18 Jul 2015 10:24:28 +0200
-Subject: [PATCH] Set locale to the user specified locale
-
----
- main.cpp | 5 ++---
- test/testrunner.cpp | 7 ++-----
- 2 files changed, 4 insertions(+), 8 deletions(-)
-
-diff --git a/main.cpp b/main.cpp
-index 6cb6c55..7cb7089 100644
---- a/main.cpp
-+++ b/main.cpp
-@@ -54,10 +54,9 @@ int main(int argc, char** argv)
- string outputFile;
- string imageFormat;
-
-- if (!setlocale(LC_CTYPE, "en_US.UTF-8"))
-+ if (!std::setlocale(LC_CTYPE, ""))
- {
-- std::cerr << "Locale not specified. Check LANG, LC_CTYPE, LC_ALL" << std::endl;
-- return 1;
-+ std::cerr << "Failed to set locale" << std::endl;
- }
-
- while ((option = getopt (argc, argv, "i:o:s:t:q:c:afwhvp")) != -1)
-diff --git a/test/testrunner.cpp b/test/testrunner.cpp
-index 7023d25..20a4903 100644
---- a/test/testrunner.cpp
-+++ b/test/testrunner.cpp
-@@ -4,12 +4,9 @@
- #include <gtest/gtest.h>
-
- int main(int argc, char **argv) {
-- std::cout << "Running ffmpegthumbnailer tests" << std::endl;
--
-- if (!setlocale(LC_CTYPE, "en_US.UTF-8"))
-+ if (!std::setlocale(LC_CTYPE, ""))
- {
-- std::cerr << "Locale not specified. Check LANG, LC_CTYPE, LC_ALL" << std::endl;
-- return 1;
-+ std::cerr << "Failed to set locale" << std::endl;
- }
-
- testing::InitGoogleTest(&argc, argv);