summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-04-25 07:46:21 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-04-25 07:46:21 +0200
commitfbac577b3632a6898d6c73791294577f932a4250 (patch)
tree454f9af42e66fa3c9ef17894da2e82a07cb94e6a /media-sound
parentdev-ruby/rspec-rails: add 5.1.2 (diff)
downloadgentoo-fbac577b3632a6898d6c73791294577f932a4250.tar.gz
gentoo-fbac577b3632a6898d6c73791294577f932a4250.tar.bz2
gentoo-fbac577b3632a6898d6c73791294577f932a4250.zip
media-sound/din: bump to 54
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/din/Manifest1
-rw-r--r--media-sound/din/din-54.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-sound/din/Manifest b/media-sound/din/Manifest
index 2598c8cc9ec3..ed7850d4c2a8 100644
--- a/media-sound/din/Manifest
+++ b/media-sound/din/Manifest
@@ -1 +1,2 @@
DIST din-53.1.tar.gz 3708022 BLAKE2B 882d4ae6cbe24c3d7fc326df3f3630d7ea7cd65b5d53c4751844dc3edcf9d533cd7cfe58fed4c46766fab6b4983e75f75145206b5362bceb27382d02705b9a36 SHA512 42058b00402e726869af8a5cb8eb9b34e7b1709185c972d3f3b633a980ad7de57a143ca0ce854ce681ec67b81cd6dd2b2b06023a15d3f1b1bd54c4ac643b6096
+DIST din-54.tar.gz 3710611 BLAKE2B 2a7540d9a413c0f83b2cfc7373b1c0fdd40012ae725f162810e4d3165e3bc669661860fd653eaed8c7f2eeed7f015ff50ce6082ce8de04bd035bf395ca018d6a SHA512 8831e6d838ba06373b13574701929f96a508f2899618509b3e79f23cb0aa11c34b347fa00b4fa765a7668c7db54733be2c9146b8e783d3fe07e3ea4ce2707bd8
diff --git a/media-sound/din/din-54.ebuild b/media-sound/din/din-54.ebuild
new file mode 100644
index 000000000000..1ff40dd5f7de
--- /dev/null
+++ b/media-sound/din/din-54.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools edos2unix xdg
+
+DESCRIPTION="a software musical instrument and audio synthesizer"
+HOMEPAGE="https://dinisnoise.org/"
+SRC_URI="https://archive.org/download/dinisnoise_source_code/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa jack"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ media-libs/libsdl:=
+ virtual/glu
+ virtual/opengl
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="|| ( alsa jack )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-52-makefile.patch"
+ "${FILESDIR}/${PN}-48-fix-random-constants.patch"
+)
+
+src_prepare() {
+ default
+
+ edos2unix pixmaps/${PN}.desktop
+
+ use jack && (sed -i "s/-lasound/-ljack/g" src/Makefile.am || die "Failed to fix jack linking")
+
+ eautoreconf
+}
+
+src_configure() {
+ # Jack takes over alsa.
+ local sound_engine
+
+ use jack && sound_engine="UNIX_JACK" || sound_engine="LINUX_ALSA"
+
+ econf CXXFLAGS="${CXXFLAGS} -D__${sound_engine}__"
+}