summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuan Liao <liaoyuan@gmail.com>2021-03-29 14:25:59 -0700
committerSam James <sam@gentoo.org>2021-06-01 00:27:53 +0000
commitd91186acd041d88e710e17f17422819edf13d5c1 (patch)
treef632bce3c0a859e0c7aa6dc753365fb9d30d36fb /media-sound
parentdev-lang/hy: drop 0.17.0 version, enable tests (diff)
downloadgentoo-d91186acd041d88e710e17f17422819edf13d5c1.tar.gz
gentoo-d91186acd041d88e710e17f17422819edf13d5c1.tar.bz2
gentoo-d91186acd041d88e710e17f17422819edf13d5c1.zip
media-sound/lollypop: Version bump 1.4.18
Closes: https://bugs.gentoo.org/769377 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Yuan Liao <liaoyuan@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20190 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-1.4.18.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index 856286fccc8a..d80dd4dba886 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1 +1,2 @@
DIST lollypop-1.2.35.tar.xz 509916 BLAKE2B 8cf9ea74287b6ac7d4942c2312cc4d6e07d4748d505cc9e45a896129f9e4a43ef5c65c0c18764597d7ce3c4d2fc93804c501f68ea3b67625e200497613077af6 SHA512 179fa5e77482db35de9e30e392e6d07bb5c832d5d1decaee06982570bdcbb809dc99375eeb6fe3dce75829af3570953ce517e3b4eaabceac807b9d5c382bd53e
+DIST lollypop-1.4.18.tar.xz 575120 BLAKE2B 62ff404c0e7c2ac7029ebb45143db35b0b93b30bfc386fb08aa4a2fc10916efb190118f41e40a0f795bef4f8d0b21b0353b9e27bbb75c5471132145028fc8b27 SHA512 17f2db91a56fd140c66c251732eca4b2a6cc1849b5dc72f0a4014c766c64eee475bc9d2305d307e2a54184ab5dd812a5fb27b39acf60a1c468770d1d34307982
diff --git a/media-sound/lollypop/lollypop-1.4.18.ebuild b/media-sound/lollypop/lollypop-1.4.18.ebuild
new file mode 100644
index 000000000000..6837244ef5e6
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.4.18.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_REQ_USE="sqlite"
+inherit python-single-r1 gnome2-utils meson xdg
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo(+)]
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pkgconfig[${PYTHON_MULTI_USEDEP}]
+ ')
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python
+ dev-python/gst-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ ')
+ gui-libs/libhandy:1
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+src_install() {
+ meson_src_install
+ python_optimize
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}