summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-29 23:38:16 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-29 23:38:16 +0200
commitbb0ce052fbbba73856638ad11276f2f39eb94574 (patch)
treef58bea796c7c215a459075775b91a5dc6d192b6b /media-sound
parentmedia-sound/easytag: update EAPI 6 -> 8 (diff)
downloadgentoo-bb0ce052fbbba73856638ad11276f2f39eb94574.tar.gz
gentoo-bb0ce052fbbba73856638ad11276f2f39eb94574.tar.bz2
gentoo-bb0ce052fbbba73856638ad11276f2f39eb94574.zip
media-sound/ezstream: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ezstream/ezstream-0.6.0-r2.ebuild (renamed from media-sound/ezstream/ezstream-0.6.0-r1.ebuild)17
1 files changed, 9 insertions, 8 deletions
diff --git a/media-sound/ezstream/ezstream-0.6.0-r1.ebuild b/media-sound/ezstream/ezstream-0.6.0-r2.ebuild
index 665c2a35883f..d9cb6fb09888 100644
--- a/media-sound/ezstream/ezstream-0.6.0-r1.ebuild
+++ b/media-sound/ezstream/ezstream-0.6.0-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="A command line source client for Icecast media streaming servers"
HOMEPAGE="https://www.icecast.org/ezstream/"
@@ -12,19 +12,20 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="taglib"
-COMMON_DEPEND="dev-libs/libxml2
+DEPEND="
+ dev-libs/libxml2
>=media-libs/libshout-2.2
!taglib? ( media-libs/libvorbis )
taglib? ( media-libs/taglib )"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="
+ ${DEPEND}
net-misc/icecast"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
+BDEPEND="virtual/pkgconfig"
src_configure() {
econf \
--enable-examplesdir='$(docdir)/examples' \
- $(use_with taglib taglib "/usr")
+ $(use_with taglib taglib "${ESYSROOT}"/usr)
}
src_install() {
@@ -33,5 +34,5 @@ src_install() {
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
- rm -f "${D%/}"/usr/share/doc/${PF}/COPYING
+ rm -f "${ED}"/usr/share/doc/${PF}/COPYING || die
}