summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-02-25 09:02:41 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-02-25 10:09:33 +0200
commit5985a749414f3184f62a31ee6b3c9fd6d4cff538 (patch)
tree81476ae5945e19b025f07f170d7c2b0108b6c953 /media-sound
parentdev-python/botocore: Stabilize 1.29.74 ALLARCHES, #896394 (diff)
downloadgentoo-5985a749414f3184f62a31ee6b3c9fd6d4cff538.tar.gz
gentoo-5985a749414f3184f62a31ee6b3c9fd6d4cff538.tar.bz2
gentoo-5985a749414f3184f62a31ee6b3c9fd6d4cff538.zip
media-sound/beets: remove unused patches
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/29783 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/beets/files/1.4.9-0001-compatibility-with-breaking-changes-to-the-ast-modul.patch53
-rw-r--r--media-sound/beets/files/1.4.9-0002-Disable-test_completion.patch74
-rw-r--r--media-sound/beets/files/1.4.9-0003-Try-to-work-around-a-Werkzeug-change.patch25
-rw-r--r--media-sound/beets/files/1.4.9-0004-Fix-3608-Replace-discogs-client-with-python3-discogs.patch134
-rw-r--r--media-sound/beets/files/1.5.0-0001-Remove-test_completion.patch74
5 files changed, 0 insertions, 360 deletions
diff --git a/media-sound/beets/files/1.4.9-0001-compatibility-with-breaking-changes-to-the-ast-modul.patch b/media-sound/beets/files/1.4.9-0001-compatibility-with-breaking-changes-to-the-ast-modul.patch
deleted file mode 100644
index f9268b17ca64..000000000000
--- a/media-sound/beets/files/1.4.9-0001-compatibility-with-breaking-changes-to-the-ast-modul.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 86af366abab51b45ad1b06d330d384bc810e45c9 Mon Sep 17 00:00:00 2001
-From: wisp3rwind <17089248+wisp3rwind@users.noreply.github.com>
-Date: Tue, 9 Jun 2020 19:34:31 +0200
-Subject: [PATCH] compatibility with breaking changes to the ast module
-
-new in 3.10, also backported to 3.8 and 3.9: https://github.com/python/cpython/pull/20649
-In fact, our generation of some Literals has been invalid since Python
-3.4, fix that too.
----
- beets/util/functemplate.py | 29 ++--
- docs/changelog.rst | 275 ++++++++++++++++++++++++++++++++++++-
- 2 files changed, 294 insertions(+), 10 deletions(-)
-
-diff --git a/beets/util/functemplate.py b/beets/util/functemplate.py
-index af22b790..266534a9 100644
---- a/beets/util/functemplate.py
-+++ b/beets/util/functemplate.py
-@@ -73,15 +73,26 @@ def ex_literal(val):
- """An int, float, long, bool, string, or None literal with the given
- value.
- """
-- if val is None:
-- return ast.Name('None', ast.Load())
-- elif isinstance(val, six.integer_types):
-- return ast.Num(val)
-- elif isinstance(val, bool):
-- return ast.Name(bytes(val), ast.Load())
-- elif isinstance(val, six.string_types):
-- return ast.Str(val)
-- raise TypeError(u'no literal for {0}'.format(type(val)))
-+ if sys.version_info[:2] < (3, 4):
-+ if val is None:
-+ return ast.Name('None', ast.Load())
-+ elif isinstance(val, six.integer_types):
-+ return ast.Num(val)
-+ elif isinstance(val, bool):
-+ return ast.Name(bytes(val), ast.Load())
-+ elif isinstance(val, six.string_types):
-+ return ast.Str(val)
-+ raise TypeError(u'no literal for {0}'.format(type(val)))
-+ elif sys.version_info[:2] < (3, 6):
-+ if val in [None, True, False]:
-+ return ast.NameConstant(val)
-+ elif isinstance(val, six.integer_types):
-+ return ast.Num(val)
-+ elif isinstance(val, six.string_types):
-+ return ast.Str(val)
-+ raise TypeError(u'no literal for {0}'.format(type(val)))
-+ else:
-+ return ast.Constant(val)
-
-
- def ex_varassign(name, expr):
diff --git a/media-sound/beets/files/1.4.9-0002-Disable-test_completion.patch b/media-sound/beets/files/1.4.9-0002-Disable-test_completion.patch
deleted file mode 100644
index c60e24d65898..000000000000
--- a/media-sound/beets/files/1.4.9-0002-Disable-test_completion.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From f6258c2ff3f3f979d72c149e44f4eecb02cb10a2 Mon Sep 17 00:00:00 2001
-From: Guillaume Seren <guillaumeseren@gmail.com>
-Date: Tue, 29 Sep 2020 16:46:06 +0200
-Subject: [PATCH] Disable test_completion
-
-Know issue by upstream https://github.com/beetbox/beets/issues/1876
----
- test/test_ui.py | 50 -------------------------------------------------
- 1 file changed, 50 deletions(-)
-
-diff --git a/test/test_ui.py b/test/test_ui.py
-index 8267c9be..bcb6c3bf 100644
---- a/test/test_ui.py
-+++ b/test/test_ui.py
-@@ -1167,56 +1167,6 @@ class PluginTest(_common.TestCase, TestHelper):
- self.run_command('test', lib=None)
-
-
--@_common.slow_test()
--class CompletionTest(_common.TestCase, TestHelper):
-- def test_completion(self):
-- # Load plugin commands
-- config['pluginpath'] = [_common.PLUGINPATH]
-- config['plugins'] = ['test']
--
-- # Do not load any other bash completion scripts on the system.
-- env = dict(os.environ)
-- env['BASH_COMPLETION_DIR'] = os.devnull
-- env['BASH_COMPLETION_COMPAT_DIR'] = os.devnull
--
-- # Open a `bash` process to run the tests in. We'll pipe in bash
-- # commands via stdin.
-- cmd = os.environ.get('BEETS_TEST_SHELL', '/bin/bash --norc').split()
-- if not has_program(cmd[0]):
-- self.skipTest(u'bash not available')
-- tester = subprocess.Popen(cmd, stdin=subprocess.PIPE,
-- stdout=subprocess.PIPE, env=env)
--
-- # Load bash_completion library.
-- for path in commands.BASH_COMPLETION_PATHS:
-- if os.path.exists(util.syspath(path)):
-- bash_completion = path
-- break
-- else:
-- self.skipTest(u'bash-completion script not found')
-- try:
-- with open(util.syspath(bash_completion), 'rb') as f:
-- tester.stdin.writelines(f)
-- except IOError:
-- self.skipTest(u'could not read bash-completion script')
--
-- # Load completion script.
-- self.io.install()
-- self.run_command('completion', lib=None)
-- completion_script = self.io.getoutput().encode('utf-8')
-- self.io.restore()
-- tester.stdin.writelines(completion_script.splitlines(True))
--
-- # Load test suite.
-- test_script_name = os.path.join(_common.RSRC, b'test_completion.sh')
-- with open(test_script_name, 'rb') as test_script_file:
-- tester.stdin.writelines(test_script_file)
-- out, err = tester.communicate()
-- if tester.returncode != 0 or out != b'completion tests passed\n':
-- print(out.decode('utf-8'))
-- self.fail(u'test/test_completion.sh did not execute properly')
--
--
- class CommonOptionsParserCliTest(unittest.TestCase, TestHelper):
- """Test CommonOptionsParser and formatting LibModel formatting on 'list'
- command.
---
-2.26.2
-
diff --git a/media-sound/beets/files/1.4.9-0003-Try-to-work-around-a-Werkzeug-change.patch b/media-sound/beets/files/1.4.9-0003-Try-to-work-around-a-Werkzeug-change.patch
deleted file mode 100644
index 9833d3f3f006..000000000000
--- a/media-sound/beets/files/1.4.9-0003-Try-to-work-around-a-Werkzeug-change.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From d43d54e21cde97f57f19486925ab56b419254cc8 Mon Sep 17 00:00:00 2001
-From: Adrian Sampson <adrian@radbox.org>
-Date: Thu, 6 Feb 2020 22:22:54 -0500
-Subject: [PATCH] Try to work around a Werkzeug change?
-
----
- beetsplug/web/__init__.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/beetsplug/web/__init__.py b/beetsplug/web/__init__.py
-index f53fb3a9..21ff5d94 100644
---- a/beetsplug/web/__init__.py
-+++ b/beetsplug/web/__init__.py
-@@ -169,7 +169,7 @@ class IdListConverter(BaseConverter):
- return ids
-
- def to_url(self, value):
-- return ','.join(value)
-+ return ','.join(str(v) for v in value)
-
-
- class QueryConverter(PathConverter):
---
-2.26.2
-
diff --git a/media-sound/beets/files/1.4.9-0004-Fix-3608-Replace-discogs-client-with-python3-discogs.patch b/media-sound/beets/files/1.4.9-0004-Fix-3608-Replace-discogs-client-with-python3-discogs.patch
deleted file mode 100644
index f7eb3d26b758..000000000000
--- a/media-sound/beets/files/1.4.9-0004-Fix-3608-Replace-discogs-client-with-python3-discogs.patch
+++ /dev/null
@@ -1,134 +0,0 @@
-From 0da62a5ed7aa5fcfc8501a06f26c3af6afa8bc52 Mon Sep 17 00:00:00 2001
-From: George Rawlinson <george@rawlinson.net.nz>
-Date: Thu, 25 Feb 2021 20:00:34 +1300
-Subject: [PATCH] Fix #3608: Replace discogs-client with python3-discogs-client
-
-discogs-client has been deprecated since June 2020, the replacement
-is actively developed by the community and does not have any breaking
-API changes.
-
-Signed-off-by: George Rawlinson <george@rawlinson.net.nz>
----
- beetsplug/discogs.py | 2 +-
- docs/plugins/discogs.rst | 8 +++----
- setup.py | 50 +++++++++++++++++++++++++++-------------
- 4 files changed, 41 insertions(+), 21 deletions(-)
-
-diff --git a/beetsplug/discogs.py b/beetsplug/discogs.py
-index 5a2bf57e..78d94eb1 100644
---- a/beetsplug/discogs.py
-+++ b/beetsplug/discogs.py
-@@ -14,7 +14,7 @@
- # included in all copies or substantial portions of the Software.
-
- """Adds Discogs album search support to the autotagger. Requires the
--discogs-client library.
-+python3-discogs-client library.
- """
- from __future__ import division, absolute_import, print_function
-
- For plugin developers:
-
-diff --git a/docs/plugins/discogs.rst b/docs/plugins/discogs.rst
-index a02b3459..f8406fd2 100644
---- a/docs/plugins/discogs.rst
-+++ b/docs/plugins/discogs.rst
-@@ -10,9 +10,9 @@ Installation
- ------------
-
- To use the ``discogs`` plugin, first enable it in your configuration (see
--:ref:`using-plugins`). Then, install the `discogs-client`_ library by typing::
-+:ref:`using-plugins`). Then, install the `python3-discogs-client`_ library by typing::
-
-- pip install discogs-client
-+ pip install python3-discogs-client
-
- You will also need to register for a `Discogs`_ account, and provide
- authentication credentials via a personal access token or an OAuth2
-@@ -36,7 +36,7 @@ Authentication via Personal Access Token
-
- As an alternative to OAuth, you can get a token from Discogs and add it to
- your configuration.
--To get a personal access token (called a "user token" in the `discogs-client`_
-+To get a personal access token (called a "user token" in the `python3-discogs-client`_
- documentation), login to `Discogs`_, and visit the
- `Developer settings page
- <https://www.discogs.com/settings/developers>`_. Press the ``Generate new
-@@ -57,4 +57,4 @@ Here are two things you can try:
- * Make sure that your system clock is accurate. The Discogs servers can reject
- your request if your clock is too out of sync.
-
--.. _discogs-client: https://github.com/discogs/discogs_client
-+.. _python3-discogs-client: https://github.com/joalla/discogs_client
-diff --git a/setup.py b/setup.py
-index 79278f8b..768c40a0 100755
---- a/setup.py
-+++ b/setup.py
-@@ -107,30 +107,48 @@ setup(
- ['colorama'] if (sys.platform == 'win32') else []
- ),
-
-- tests_require=[
-- 'beautifulsoup4',
-- 'flask',
-- 'mock',
-- 'pylast',
-- 'rarfile',
-- 'responses',
-- 'pyxdg',
-- 'python-mpd2',
-- 'discogs-client'
-- ] + (
-- # Tests for the thumbnails plugin need pathlib on Python 2 too.
-- ['pathlib'] if (sys.version_info < (3, 4, 0)) else []
-- ),
--
- # Plugin (optional) dependencies:
- extras_require={
-+ 'test': [
-+ 'beautifulsoup4',
-+ 'coverage',
-+ 'flask',
-+ 'mock',
-+ 'pylast',
-+ 'pytest',
-+ 'python-mpd2',
-+ 'pyxdg',
-+ 'responses>=0.3.0',
-+ 'requests_oauthlib',
-+ 'reflink',
-+ ] + (
-+ # Tests for the thumbnails plugin need pathlib on Python 2 too.
-+ ['pathlib'] if (sys.version_info < (3, 4, 0)) else []
-+ ) + [
-+ 'rarfile<4' if sys.version_info < (3, 6, 0) else 'rarfile',
-+ ] + [
-+ 'discogs-client' if (sys.version_info < (3, 0, 0))
-+ else 'python3-discogs-client'
-+ ],
-+ 'lint': [
-+ 'flake8',
-+ 'flake8-coding',
-+ 'flake8-docstrings',
-+ 'flake8-future-import',
-+ 'pep8-naming',
-+ ],
-+
-+ # Plugin (optional) dependencies:
- 'absubmit': ['requests'],
- 'fetchart': ['requests', 'Pillow'],
- 'embedart': ['Pillow'],
- 'embyupdate': ['requests'],
- 'chroma': ['pyacoustid'],
- 'gmusic': ['gmusicapi'],
-- 'discogs': ['discogs-client>=2.2.1'],
-+ 'discogs': (
-+ ['discogs-client' if (sys.version_info < (3, 0, 0))
-+ else 'python3-discogs-client']
-+ ),
- 'beatport': ['requests-oauthlib>=0.6.1'],
- 'kodiupdate': ['requests'],
- 'lastgenre': ['pylast'],
---
-2.26.3
-
diff --git a/media-sound/beets/files/1.5.0-0001-Remove-test_completion.patch b/media-sound/beets/files/1.5.0-0001-Remove-test_completion.patch
deleted file mode 100644
index 16c1a6fe5fa1..000000000000
--- a/media-sound/beets/files/1.5.0-0001-Remove-test_completion.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From a992bf194803d3598a8edc054a767858b0355a78 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Arsen=20Arsenovi=C4=87?= <arsen@aarsen.me>
-Date: Thu, 21 Oct 2021 23:16:45 +0200
-Subject: [PATCH] Remove test_completion
-
-Known issue: https://github.com/beetbox/beets/issues/1876
----
- test/test_ui.py | 50 -------------------------------------------------
- 1 file changed, 50 deletions(-)
-
-diff --git a/test/test_ui.py b/test/test_ui.py
-index 5cfed1fd..48e7cc85 100644
---- a/test/test_ui.py
-+++ b/test/test_ui.py
-@@ -1209,56 +1209,6 @@ class PluginTest(_common.TestCase, TestHelper):
- self.run_command('test', lib=None)
-
-
--@_common.slow_test()
--class CompletionTest(_common.TestCase, TestHelper):
-- def test_completion(self):
-- # Load plugin commands
-- config['pluginpath'] = [_common.PLUGINPATH]
-- config['plugins'] = ['test']
--
-- # Do not load any other bash completion scripts on the system.
-- env = dict(os.environ)
-- env['BASH_COMPLETION_DIR'] = os.devnull
-- env['BASH_COMPLETION_COMPAT_DIR'] = os.devnull
--
-- # Open a `bash` process to run the tests in. We'll pipe in bash
-- # commands via stdin.
-- cmd = os.environ.get('BEETS_TEST_SHELL', '/bin/bash --norc').split()
-- if not has_program(cmd[0]):
-- self.skipTest(u'bash not available')
-- tester = subprocess.Popen(cmd, stdin=subprocess.PIPE,
-- stdout=subprocess.PIPE, env=env)
--
-- # Load bash_completion library.
-- for path in commands.BASH_COMPLETION_PATHS:
-- if os.path.exists(util.syspath(path)):
-- bash_completion = path
-- break
-- else:
-- self.skipTest(u'bash-completion script not found')
-- try:
-- with open(util.syspath(bash_completion), 'rb') as f:
-- tester.stdin.writelines(f)
-- except IOError:
-- self.skipTest(u'could not read bash-completion script')
--
-- # Load completion script.
-- self.io.install()
-- self.run_command('completion', lib=None)
-- completion_script = self.io.getoutput().encode('utf-8')
-- self.io.restore()
-- tester.stdin.writelines(completion_script.splitlines(True))
--
-- # Load test suite.
-- test_script_name = os.path.join(_common.RSRC, b'test_completion.sh')
-- with open(test_script_name, 'rb') as test_script_file:
-- tester.stdin.writelines(test_script_file)
-- out, err = tester.communicate()
-- if tester.returncode != 0 or out != b'completion tests passed\n':
-- print(out.decode('utf-8'))
-- self.fail(u'test/test_completion.sh did not execute properly')
--
--
- class CommonOptionsParserCliTest(unittest.TestCase, TestHelper):
- """Test CommonOptionsParser and formatting LibModel formatting on 'list'
- command.
---
-2.32.0
-