summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-02-28 08:26:55 +0100
committerMichał Górny <mgorny@gentoo.org>2019-02-28 18:41:29 +0100
commit2c21823dcb172724e5229e8c59f7e0e1d296ba4a (patch)
treef601c902be8e09d737a047733824321ba3cfc2d0 /media-sound/xfmpc/xfmpc-0.2.90.ebuild
parentdev-db/sqlitebrowser: add missing DEPEND (diff)
downloadgentoo-2c21823dcb172724e5229e8c59f7e0e1d296ba4a.tar.gz
gentoo-2c21823dcb172724e5229e8c59f7e0e1d296ba4a.tar.bz2
gentoo-2c21823dcb172724e5229e8c59f7e0e1d296ba4a.zip
media-sound/xfmpc: Bump to 0.2.90 (GTK+3 port)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-sound/xfmpc/xfmpc-0.2.90.ebuild')
-rw-r--r--media-sound/xfmpc/xfmpc-0.2.90.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/xfmpc/xfmpc-0.2.90.ebuild b/media-sound/xfmpc/xfmpc-0.2.90.ebuild
new file mode 100644
index 000000000000..9a6ac70cb9df
--- /dev/null
+++ b/media-sound/xfmpc/xfmpc-0.2.90.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="Music Player Daemon (MPD) client for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfmpc"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/0.2/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.18:2=
+ >=media-libs/libmpd-0.15:=
+ >=x11-libs/gtk+-3.22:3=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog IDEAS NEWS README THANKS )
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}