summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-12-31 21:40:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-01 09:55:17 +0100
commitfcffd565331e9aee038536184f3a4c8cac004363 (patch)
treef8b21c2d74539831dd7303a2c50098fe104801d4 /media-sound/qsampler
parentmedia-sound/qsampler: Drop IUSE qt6 (Qt5 build option) (diff)
downloadgentoo-fcffd565331e9aee038536184f3a4c8cac004363.tar.gz
gentoo-fcffd565331e9aee038536184f3a4c8cac004363.tar.bz2
gentoo-fcffd565331e9aee038536184f3a4c8cac004363.zip
media-sound/qsampler: drop 1.0.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/qsampler')
-rw-r--r--media-sound/qsampler/qsampler-1.0.0.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/media-sound/qsampler/qsampler-1.0.0.ebuild b/media-sound/qsampler/qsampler-1.0.0.ebuild
deleted file mode 100644
index d07c734a28c1..000000000000
--- a/media-sound/qsampler/qsampler-1.0.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake xdg
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://git.code.sf.net/p/qsampler/code"
- inherit git-r3
-else
- SRC_URI="https://downloads.sourceforge.net/${PN}/${PV}/${P}.tar.gz"
- KEYWORDS="amd64 ~x86"
-fi
-
-DESCRIPTION="Graphical frontend to the LinuxSampler engine"
-HOMEPAGE="https://qsampler.sourceforge.io/ https://www.linuxsampler.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug +libgig qt6"
-
-DEPEND="
- media-libs/alsa-lib
- media-libs/liblscp:=
- x11-libs/libX11
- libgig? ( media-libs/libgig:= )
- qt6? (
- dev-qt/qtbase:6[gui,network,widgets]
- dev-qt/qtsvg:6
- )
- !qt6? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- )
-"
-RDEPEND="${DEPEND}
- media-sound/linuxsampler
-"
-BDEPEND="
- qt6? ( dev-qt/qttools:6[linguist] )
- !qt6? ( dev-qt/linguist-tools:5 )
-"
-
-DOCS=( ChangeLog README TRANSLATORS )
-
-src_configure() {
- local mycmakeargs=(
- -DCONFIG_DEBUG=$(usex debug 1 0)
- -DCONFIG_LIBGIG=$(usex libgig 1 0)
- -DCONFIG_QT6=$(usex qt6 1 0)
- )
- cmake_src_configure
-}