summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-11-14 11:44:41 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2023-11-14 11:44:41 +0100
commit48ae05392a87d29f33b85cea2a38de9b69164408 (patch)
treedfb30c0abe11667336baa844bb26747195501442 /media-sound/mpg123
parentmedia-sound/hydrogen: updated live ebuild patches + scrubbed patches (diff)
downloadgentoo-48ae05392a87d29f33b85cea2a38de9b69164408.tar.gz
gentoo-48ae05392a87d29f33b85cea2a38de9b69164408.tar.bz2
gentoo-48ae05392a87d29f33b85cea2a38de9b69164408.zip
media-sound/mpg123: dropped obsolete 1.31.3-r1 & 1.31.3
Bug: https://bugs.gentoo.org/917112 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/mpg123')
-rw-r--r--media-sound/mpg123/Manifest1
-rw-r--r--media-sound/mpg123/mpg123-1.31.3-r1.ebuild110
-rw-r--r--media-sound/mpg123/mpg123-1.31.3.ebuild110
3 files changed, 0 insertions, 221 deletions
diff --git a/media-sound/mpg123/Manifest b/media-sound/mpg123/Manifest
index af861e2f2283..1baeb7a33f18 100644
--- a/media-sound/mpg123/Manifest
+++ b/media-sound/mpg123/Manifest
@@ -1,2 +1 @@
-DIST mpg123-1.31.3.tar.bz2 1094474 BLAKE2B 343bca53e067485dba438a177ba65f38d512c4aaac6f413bb1e070f99d6407f9a694899f06fbd3577ef287b4e898b38ac3585f86d18f643cab15f678d3105c11 SHA512 5dd550e06f5d0d432cac1b7e546215e56378b44588c1a98031498473211e08bc4228de45be41f7ba764f7f6c0eb752a6501235bcc3712c9a8d8852ae3c607d98
DIST mpg123-1.32.3.tar.bz2 1111054 BLAKE2B 67f889403c2bb639d675ec5ebea5a19c4b7174971d62bdd8d940ad659e6b0c06dada38422fc9d71b878917aa89e305ec48c8faa78d65d507cd6a0c9a79951359 SHA512 946c1073b6eebfd65333ec543df1caeea25864479e9c8e153fb53d8b636cc756d8d81947f7b5cbedbbfb1ea664d3fb27562ed36e7726d95e80591bd2ad622afc
diff --git a/media-sound/mpg123/mpg123-1.31.3-r1.ebuild b/media-sound/mpg123/mpg123-1.31.3-r1.ebuild
deleted file mode 100644
index c799d036667f..000000000000
--- a/media-sound/mpg123/mpg123-1.31.3-r1.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs libtool multilib-minimal
-
-DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
-HOMEPAGE="https://www.mpg123.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ~ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext cpu_flags_ppc_altivec alsa coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
-
-# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
-# Note: build system prefers libsdl2 > libsdl. We could in theory add both
-# but it's tricky when it comes to handling switching between them properly.
-# We'd need a USE flag for both sdl1 and sdl2 and to make them clash.
-RDEPEND="
- dev-libs/libltdl:0
- alsa? ( media-libs/alsa-lib )
- jack? ( virtual/jack )
- nas? ( media-libs/nas )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-libs/libpulse )
- sdl? ( media-libs/libsdl2 )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/libtool
- virtual/pkgconfig
-"
-IDEPEND="app-eselect/eselect-mpg123"
-
-DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
-
-src_prepare() {
- default
- elibtoolize # for Darwin bundles
-}
-
-multilib_src_configure() {
- local _audio=dummy
- local _output=dummy
- local _cpu=generic_fpu
-
- # Build fails without -D_GNU_SOURCE like this:
- # error: ‘struct hostent’ has no member named ‘h_addr’
- append-cflags -D_GNU_SOURCE
-
- append-lfs-flags
-
- if $(multilib_is_native_abi) ; then
- local flag
- for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
- if use ${flag}; then
- _audio+=" ${flag/pulseaudio/pulse}"
- _output=${flag/pulseaudio/pulse}
- fi
- done
- fi
-
- use cpu_flags_ppc_altivec && _cpu=altivec
-
- if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
- use cpu_flags_x86_sse && _cpu=x86-64
- elif use x86 && gcc-specs-pie ; then
- # Don't use any mmx, 3dnow, sse and 3dnowext
- # bug #164504
- _cpu=generic_fpu
- else
- use cpu_flags_x86_mmx && _cpu=mmx
- use cpu_flags_x86_3dnow && _cpu=3dnow
- use cpu_flags_x86_sse && _cpu=x86
- use cpu_flags_x86_3dnowext && _cpu=x86
- fi
-
- local myconf=(
- --with-optimization=0
- --with-audio="${_audio}"
- --with-default-audio=${_output}
- --with-cpu=${_cpu}
- --enable-network
- $(use_enable ipv6)
- --enable-int-quality=$(usex int-quality)
- )
-
- multilib_is_native_abi || myconf+=( --disable-modules )
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
-
- if ! $(multilib_is_native_abi) ; then
- sed -i -e 's:src doc:src/libmpg123:' Makefile || die
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
- mv "${ED}"/usr/bin/mpg123{,-mpg123}
- find "${ED}" -type f -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- eselect mpg123 update ifunset
-}
-
-pkg_postrm() {
- eselect mpg123 update ifunset
-}
diff --git a/media-sound/mpg123/mpg123-1.31.3.ebuild b/media-sound/mpg123/mpg123-1.31.3.ebuild
deleted file mode 100644
index 4834ae56d825..000000000000
--- a/media-sound/mpg123/mpg123-1.31.3.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs libtool multilib-minimal
-
-DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
-HOMEPAGE="https://www.mpg123.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext cpu_flags_ppc_altivec alsa coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
-
-# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
-# Note: build system prefers libsdl2 > libsdl. We could in theory add both
-# but it's tricky when it comes to handling switching between them properly.
-# We'd need a USE flag for both sdl1 and sdl2 and to make them clash.
-RDEPEND="
- dev-libs/libltdl:0
- alsa? ( media-libs/alsa-lib )
- jack? ( virtual/jack )
- nas? ( media-libs/nas )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- sdl? ( media-libs/libsdl2 )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/libtool
- virtual/pkgconfig
-"
-IDEPEND="app-eselect/eselect-mpg123"
-
-DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
-
-src_prepare() {
- default
- elibtoolize # for Darwin bundles
-}
-
-multilib_src_configure() {
- local _audio=dummy
- local _output=dummy
- local _cpu=generic_fpu
-
- # Build fails without -D_GNU_SOURCE like this:
- # error: ‘struct hostent’ has no member named ‘h_addr’
- append-cflags -D_GNU_SOURCE
-
- append-lfs-flags
-
- if $(multilib_is_native_abi) ; then
- local flag
- for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
- if use ${flag}; then
- _audio+=" ${flag/pulseaudio/pulse}"
- _output=${flag/pulseaudio/pulse}
- fi
- done
- fi
-
- use cpu_flags_ppc_altivec && _cpu=altivec
-
- if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
- use cpu_flags_x86_sse && _cpu=x86-64
- elif use x86 && gcc-specs-pie ; then
- # Don't use any mmx, 3dnow, sse and 3dnowext
- # bug #164504
- _cpu=generic_fpu
- else
- use cpu_flags_x86_mmx && _cpu=mmx
- use cpu_flags_x86_3dnow && _cpu=3dnow
- use cpu_flags_x86_sse && _cpu=x86
- use cpu_flags_x86_3dnowext && _cpu=x86
- fi
-
- local myconf=(
- --with-optimization=0
- --with-audio="${_audio}"
- --with-default-audio=${_output}
- --with-cpu=${_cpu}
- --enable-network
- $(use_enable ipv6)
- --enable-int-quality=$(usex int-quality)
- )
-
- multilib_is_native_abi || myconf+=( --disable-modules )
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
-
- if ! $(multilib_is_native_abi) ; then
- sed -i -e 's:src doc:src/libmpg123:' Makefile || die
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
- mv "${ED}"/usr/bin/mpg123{,-mpg123}
- find "${ED}" -type f -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- eselect mpg123 update ifunset
-}
-
-pkg_postrm() {
- eselect mpg123 update ifunset
-}