summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/moodbar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/moodbar')
-rw-r--r--media-sound/moodbar/Manifest1
-rw-r--r--media-sound/moodbar/files/moodbar-0.1.2-gthread_init.patch13
-rw-r--r--media-sound/moodbar/metadata.xml6
-rw-r--r--media-sound/moodbar/moodbar-0.1.2.ebuild30
4 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/moodbar/Manifest b/media-sound/moodbar/Manifest
new file mode 100644
index 000000000000..3b201a5bcb03
--- /dev/null
+++ b/media-sound/moodbar/Manifest
@@ -0,0 +1 @@
+DIST moodbar-0.1.2.tar.gz 327715 SHA256 3d53627c3d979636e98bbe1e745ed79e98f1238148ba4f8379819f9083b3d9c4
diff --git a/media-sound/moodbar/files/moodbar-0.1.2-gthread_init.patch b/media-sound/moodbar/files/moodbar-0.1.2-gthread_init.patch
new file mode 100644
index 000000000000..028be99dc502
--- /dev/null
+++ b/media-sound/moodbar/files/moodbar-0.1.2-gthread_init.patch
@@ -0,0 +1,13 @@
+diff -ur moodbar-0.1.2.orig/analyzer/main.c moodbar-0.1.2/analyzer/main.c
+--- moodbar-0.1.2.orig/analyzer/main.c 2006-10-12 08:43:30.000000000 +0300
++++ moodbar-0.1.2/analyzer/main.c 2009-05-09 14:14:08.000000000 +0300
+@@ -262,6 +262,9 @@
+ GOptionContext *ctx;
+ GError *err = NULL;
+
++ // must be called before any other glib function is called
++ if (!g_thread_supported ()) g_thread_init(NULL);
++
+ ctx = g_option_context_new ("[INFILE] - Run moodbar analyzer");
+ g_option_context_add_group (ctx, gst_init_get_option_group ());
+ g_option_context_add_main_entries (ctx, entries, NULL);
diff --git a/media-sound/moodbar/metadata.xml b/media-sound/moodbar/metadata.xml
new file mode 100644
index 000000000000..3cbd34b008ee
--- /dev/null
+++ b/media-sound/moodbar/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/media-sound/moodbar/moodbar-0.1.2.ebuild b/media-sound/moodbar/moodbar-0.1.2.ebuild
new file mode 100644
index 000000000000..e831d833d2cc
--- /dev/null
+++ b/media-sound/moodbar/moodbar-0.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="The moodbar tool and gstreamer plugin for Amarok"
+HOMEPAGE="http://amarok.kde.org/wiki/Moodbar"
+SRC_URI="http://pwsp.net/~qbob/moodbar-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="mp3 ogg vorbis flac"
+
+RDEPEND="media-libs/gst-plugins-base:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-meta:0.10
+ sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gthread_init.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}