summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/lyvi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/lyvi')
-rw-r--r--media-sound/lyvi/Manifest1
-rw-r--r--media-sound/lyvi/lyvi-2.0.0.ebuild33
-rw-r--r--media-sound/lyvi/metadata.xml24
3 files changed, 58 insertions, 0 deletions
diff --git a/media-sound/lyvi/Manifest b/media-sound/lyvi/Manifest
new file mode 100644
index 000000000000..8e5cecada036
--- /dev/null
+++ b/media-sound/lyvi/Manifest
@@ -0,0 +1 @@
+DIST lyvi-2.0.0.tar.gz 19307 SHA256 74b1fd94807b873ba921f071d55da7359a0033a9e7398f8dc7ce378f5d200f0a SHA512 0248ceb16436be427ab38769824ce4be48998997b1997f90ddef751105e7449cff7d865e9a5895fb67c79da0eaf394baefe1a77bdc9e6c5e2b6498d64128b045 WHIRLPOOL cf73fff6fc096fe5168adb9d56593cc3e636bb679bed294bf828f0ef557ff4b7ef78534ad643f9bbdb3ad16bc221538b5a6f8e437f068084e69ecf31e620476b
diff --git a/media-sound/lyvi/lyvi-2.0.0.ebuild b/media-sound/lyvi/lyvi-2.0.0.ebuild
new file mode 100644
index 000000000000..a73cc4a3dca9
--- /dev/null
+++ b/media-sound/lyvi/lyvi-2.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple command-line lyrics viewer"
+HOMEPAGE="http://ok100.github.io/lyvi/"
+SRC_URI="https://github.com/ok100/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+KEYWORDS="amd64"
+SLOT="0"
+IUSE="mpris"
+
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/plyr[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ mpris? (
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Remove pip dependency
+ sed -e '/require/d' --in-place setup.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/media-sound/lyvi/metadata.xml b/media-sound/lyvi/metadata.xml
new file mode 100644
index 000000000000..1646c2fcad92
--- /dev/null
+++ b/media-sound/lyvi/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>witold.pilat@gmail.com</email>
+ <name>Witold Pilat</name>
+ <description>Proxy maintainer</description>
+ </maintainer>
+ <longdescription>Lyvi is a lyrics, artist info and guitar tabs
+ viewer. On supported terminals, Lyvi can also show artist photos and
+ cover images.
+ </longdescription>
+ <use>
+ <flag name="mpris">Enable MPRIS support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">ok100/lyvi</remote-id>
+ </upstream>
+</pkgmetadata>