summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-17 02:35:11 +0100
committerSam James <sam@gentoo.org>2022-06-17 13:10:05 +0100
commit903f4e0b5bc406dbaa16576e227f7965beed1e7a (patch)
treef8d1c7700653850e10e54a5daeefd5ecef9b4c2f /media-sound/frescobaldi
parentdev-python/qpageview: new package, add 0.6.2 (diff)
downloadgentoo-903f4e0b5bc406dbaa16576e227f7965beed1e7a.tar.gz
gentoo-903f4e0b5bc406dbaa16576e227f7965beed1e7a.tar.bz2
gentoo-903f4e0b5bc406dbaa16576e227f7965beed1e7a.zip
media-sound/frescobaldi: add qpageview dep
Closes: https://bugs.gentoo.org/850922 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/frescobaldi')
-rw-r--r--media-sound/frescobaldi/frescobaldi-3.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/frescobaldi/frescobaldi-3.2-r1.ebuild b/media-sound/frescobaldi/frescobaldi-3.2-r1.ebuild
new file mode 100644
index 000000000000..c0e548571f49
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-3.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 xdg
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="https://www.frescobaldi.org/"
+SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/PyQt5[gui,network,printsupport,svg,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/python-ly[${PYTHON_USEDEP}]
+ dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ dev-python/qpageview[${PYTHON_USEDEP}]
+ media-sound/lilypond"
+RDEPEND="${DEPEND}
+ x11-themes/tango-icon-theme
+"
+
+python_prepare_all() {
+ rm -r frescobaldi_app/icons/Tango || die "failed to remove tango icon theme"
+ distutils-r1_python_prepare_all
+}