summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/dvda-author/dvda-author-10.06.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/dvda-author/dvda-author-10.06.ebuild')
-rw-r--r--media-sound/dvda-author/dvda-author-10.06.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/dvda-author/dvda-author-10.06.ebuild b/media-sound/dvda-author/dvda-author-10.06.ebuild
new file mode 100644
index 000000000000..d7775dac8bed
--- /dev/null
+++ b/media-sound/dvda-author/dvda-author-10.06.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Author a DVD-Audio DVD"
+HOMEPAGE="http://dvd-audio.sourceforge.net"
+SRC_URI="mirror://sourceforge/dvd-audio/${P}-300.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=media-sound/sox-14.1[png]
+ >=media-libs/flac-1.2.1[ogg]"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2"
+
+src_prepare() {
+ # Fix parallel make
+ sed -i -e 's:^\(\tcd ${MAYBE_CDRTOOLS}\):@HAVE_CDRTOOLS_BUILD_TRUE@\1:' \
+ Makefile.in || die "sed failed"
+
+ # Don't pre-strip binaries
+ sed -i -e 's:$LIBS -s:$LIBS:' configure || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --with-config=/etc \
+ $(use_with debug debug full)
+}
+
+src_install() {
+ newbin src/dvda ${PN} || die "newbin failed"
+ insinto /etc
+ doins ${PN}.conf || die "doins failed"
+ dodoc AUTHORS BUGS ChangeLog EXAMPLES HOWTO.conf LIMITATIONS NEWS TODO \
+ || die "dodoc failed"
+}