summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2024-10-08 09:55:14 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2024-10-08 10:01:01 +0200
commit198fecde5d469bf643fed2580c5cd9e1a20637c9 (patch)
tree9d8b58feb798bb90f547b706bcf4672e570b44ab /media-radio
parentnet-firewall/ufw: enable py3.13 (diff)
downloadgentoo-198fecde5d469bf643fed2580c5cd9e1a20637c9.tar.gz
gentoo-198fecde5d469bf643fed2580c5cd9e1a20637c9.tar.bz2
gentoo-198fecde5d469bf643fed2580c5cd9e1a20637c9.zip
media-radio/xlog: add 2.0.25
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/xlog/Manifest1
-rw-r--r--media-radio/xlog/files/xlog-2.0.25-desktop.patch12
-rw-r--r--media-radio/xlog/xlog-2.0.25.ebuild83
3 files changed, 96 insertions, 0 deletions
diff --git a/media-radio/xlog/Manifest b/media-radio/xlog/Manifest
index 7172669af48c..b02dcffa010c 100644
--- a/media-radio/xlog/Manifest
+++ b/media-radio/xlog/Manifest
@@ -1 +1,2 @@
DIST xlog-2.0.24.tar.gz 11407825 BLAKE2B 0de5203d4229005ba84940443672a9787a9ab2a87565bcbf47e0a0fcf375dcddec7636d11a359a117c42b7e07ea81fd482a2684b8a75379da1fe72cbc991643d SHA512 cc96dfabf01a6c49ed7db1257cc102a469642bdd32a158b0a026da2017181060f8aace5de22ada5df42b3bc89c14448dd372332a9ff0101121570f5b1187e5ab
+DIST xlog-2.0.25.tar.gz 11425326 BLAKE2B d0d14a79090a37c45456da7120089193c02d2fb3df30e8e5780bc40287e4f3a0e4e444613a07b5135502c771c2bd650d81966fc59658140740259fcbca509c9f SHA512 3ce5b27a0529885862a8c5256162068504e05cbbca6e0fc6cf492bfabbb2aa84b82a54502319646ee49e78aac6cd2b685877ec3687fb962c59c8648e0be4e121
diff --git a/media-radio/xlog/files/xlog-2.0.25-desktop.patch b/media-radio/xlog/files/xlog-2.0.25-desktop.patch
new file mode 100644
index 000000000000..33e64f81b7a6
--- /dev/null
+++ b/media-radio/xlog/files/xlog-2.0.25-desktop.patch
@@ -0,0 +1,12 @@
+diff --git a/data/desktop/xlog.desktop b/data/desktop/xlog.desktop
+index 5be4ce1..bee2c12 100644
+--- a/data/desktop/xlog.desktop
++++ b/data/desktop/xlog.desktop
+@@ -8,5 +8,5 @@ Exec=xlog %F
+ Icon=xlog
+ Terminal=false
+ Type=Application
+-Categories=Utility;Database;HamRadio;GTK
+-MimeType=text/x-xlog
++Categories=Utility;Database;HamRadio;GTK;
++MimeType=text/x-xlog;
diff --git a/media-radio/xlog/xlog-2.0.25.ebuild b/media-radio/xlog/xlog-2.0.25.ebuild
new file mode 100644
index 000000000000..89fb8993a59b
--- /dev/null
+++ b/media-radio/xlog/xlog-2.0.25.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs xdg-utils
+MY_P=${P/_}
+
+DESCRIPTION="An amateur radio logging program"
+HOMEPAGE="https://www.nongnu.org/xlog"
+SRC_URI="https://download.savannah.gnu.org/releases/${PN}/${MY_P}.tar.gz"
+
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-libs/hamlib:=
+ dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ media-libs/libpng:0
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS data/doc/THANKS NEWS README )
+
+src_prepare() {
+ eapply_user
+ eapply "${FILESDIR}/${PN}-2.0.25-desktop.patch"
+ eapply "${FILESDIR}/${PN}-2.0.24-musl.patch"
+
+ # Drop -Werror
+ sed -i -e "s:-Werror::g" configure.ac || die
+ # fix underlinking
+ sed -i -e "s:HAMLIB_LIBS@:HAMLIB_LIBS@ -lm:g" src/Makefile.am || die
+ eautoconf
+
+ # prepare for media-radio/hamlib-4.2 change of API
+ if has_version '>=media-libs/hamlib-4.2' ; then
+ sed -i -e "s/FILPATHLEN/HAMLIB_FILPATHLEN/g" "${S}"/src/hamlib-utils.c || die
+ fi
+
+ # Fix broken png files<<
+ einfo "Fixing broken png files."
+ pushd "${S}"/data/doc/manual/output/html
+ for png in xlog-clock.png xlog-dropdown.png xlog-editbox.png; do
+ pngfix -q --out=out.png ${png}
+ mv -f out.png "${png}" || die
+ done
+ popd
+ einfo "done ..."
+
+}
+
+src_configure() {
+ # mime-update causes file collisions if enabled
+ econf --disable-mime-update
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ # build system makes it complicate to inhibit updating desktop
+ # database, so just remove the offending file
+ rm "${D}"/usr/share/applications/mimeinfo.cache || die
+ docompress -x /usr/share/doc/${PF}/{KEYS,ChangeLog,TODO,BUGS}
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}