summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-05 01:03:26 -0400
committerSam James <sam@gentoo.org>2024-05-05 12:47:12 +0100
commit925ef108801dfd2bafc4a9c2fa0d5c0b68bdf3cb (patch)
treed0a72fad98a9aecafcf03507acd0ab4d86925543 /media-plugins
parentmedia-libs/liblo: replace useless sed with configure option (diff)
downloadgentoo-925ef108801dfd2bafc4a9c2fa0d5c0b68bdf3cb.tar.gz
gentoo-925ef108801dfd2bafc4a9c2fa0d5c0b68bdf3cb.tar.bz2
gentoo-925ef108801dfd2bafc4a9c2fa0d5c0b68bdf3cb.zip
media-plugins/x42-plugins: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/860402 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/x42-plugins/x42-plugins-20220605.ebuild9
-rw-r--r--media-plugins/x42-plugins/x42-plugins-20220714.ebuild9
-rw-r--r--media-plugins/x42-plugins/x42-plugins-99999999.ebuild9
3 files changed, 21 insertions, 6 deletions
diff --git a/media-plugins/x42-plugins/x42-plugins-20220605.ebuild b/media-plugins/x42-plugins/x42-plugins-20220605.ebuild
index f57cf56abcb2..48b97eecbcb1 100644
--- a/media-plugins/x42-plugins/x42-plugins-20220605.ebuild
+++ b/media-plugins/x42-plugins/x42-plugins-20220605.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Collection of LV2 plugins"
HOMEPAGE="https://github.com/x42/x42-plugins"
@@ -40,6 +40,11 @@ DEPEND="${RDEPEND}
sys-apps/help2man"
src_compile() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/860402
+ # https://github.com/x42/meters.lv2/issues/41
+ filter-lto
+
emake CC="$(tc-getCC)" STRIP="#" FONTFILE="/usr/share/fonts/dejavu/DejaVuSans-Bold.ttf"
}
diff --git a/media-plugins/x42-plugins/x42-plugins-20220714.ebuild b/media-plugins/x42-plugins/x42-plugins-20220714.ebuild
index f57cf56abcb2..48b97eecbcb1 100644
--- a/media-plugins/x42-plugins/x42-plugins-20220714.ebuild
+++ b/media-plugins/x42-plugins/x42-plugins-20220714.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Collection of LV2 plugins"
HOMEPAGE="https://github.com/x42/x42-plugins"
@@ -40,6 +40,11 @@ DEPEND="${RDEPEND}
sys-apps/help2man"
src_compile() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/860402
+ # https://github.com/x42/meters.lv2/issues/41
+ filter-lto
+
emake CC="$(tc-getCC)" STRIP="#" FONTFILE="/usr/share/fonts/dejavu/DejaVuSans-Bold.ttf"
}
diff --git a/media-plugins/x42-plugins/x42-plugins-99999999.ebuild b/media-plugins/x42-plugins/x42-plugins-99999999.ebuild
index 2ee199d0ef8f..776121d83fa4 100644
--- a/media-plugins/x42-plugins/x42-plugins-99999999.ebuild
+++ b/media-plugins/x42-plugins/x42-plugins-99999999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Collection of LV2 plugins"
HOMEPAGE="https://github.com/x42/x42-plugins"
@@ -40,6 +40,11 @@ DEPEND="${RDEPEND}
sys-apps/help2man"
src_compile() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/860402
+ # https://github.com/x42/meters.lv2/issues/41
+ filter-lto
+
emake CC="$(tc-getCC)" STRIP="#" FONTFILE="/usr/share/fonts/dejavu/DejaVuSans-Bold.ttf"
}