summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-10-31 16:23:21 -0400
committerCraig Andrews <candrews@gentoo.org>2020-10-31 16:27:37 -0400
commit1b16c26e2a38b1a6c854d181518bfdbad2856489 (patch)
treeb52d2900e7afd9048da197913f069cf3194c69a7 /media-plugins/kodi-inputstream-rtmp
parentmedia-plugins/kodi-pvr-vuplus: 7.0.0 version bump (diff)
downloadgentoo-1b16c26e2a38b1a6c854d181518bfdbad2856489.tar.gz
gentoo-1b16c26e2a38b1a6c854d181518bfdbad2856489.tar.bz2
gentoo-1b16c26e2a38b1a6c854d181518bfdbad2856489.zip
media-plugins/kodi-inputstream-rtmp: 3.3.0 version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-inputstream-rtmp')
-rw-r--r--media-plugins/kodi-inputstream-rtmp/Manifest1
-rw-r--r--media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-3.3.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-plugins/kodi-inputstream-rtmp/Manifest b/media-plugins/kodi-inputstream-rtmp/Manifest
index cb6746b37afd..c292c9bf61ad 100644
--- a/media-plugins/kodi-inputstream-rtmp/Manifest
+++ b/media-plugins/kodi-inputstream-rtmp/Manifest
@@ -1,2 +1,3 @@
DIST kodi-inputstream-rtmp-2.0.9.tar.gz 66408 BLAKE2B 466419ef7182c53ddbe358ffb9480f756b8ab7f1f8fe790bb7942ac1cbd14731e4ef2faa0c15d31652733fe49881cf7588a6e560e6f132b61da47d7a8e0e0367 SHA512 b38b45f6313bcf2827eabf80875840b8b24cf010e0f44c20241f8a20f438273020ebd34078562581c34c83f3c9109ec953ef1de819c85de2260f0377903fbd23
DIST kodi-inputstream-rtmp-3.1.1.tar.gz 75658 BLAKE2B 4a776d3e44326cfa8195ad75b49eecba08d4a6de6a43ea51ee31791556ed2a28536e77033d0c9833838be9a27b2a32dc5ac34c4e9ee92e7a9084b021afbd1100 SHA512 9509fe681c3e2699ebe18a3090bd31c32ccc2634ee0c3c5a686b380ce1d104ff7ec1620f6615495d26fb271164592c0cb4f287ef1852468edddfec9440773a53
+DIST kodi-inputstream-rtmp-3.3.0.tar.gz 76074 BLAKE2B d920235be127d67a73d3fe8b713459f1bc04491577d886352e0932fd13c638e694b322400c5d9512c0716aca7ef4ed5c3535a05472ea6fff5d0d5aeeebe34aeb SHA512 a981ecd904932ba372e7972137c78308f1fe6928286fead13ad692b41aed0303c7e95a1788984e69cad4984d4f36c1d875f98eeb4a0ed3608ca1c4f8335133cd
diff --git a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-3.3.0.ebuild b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-3.3.0.ebuild
new file mode 100644
index 000000000000..a0b89342cd1c
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-3.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kodi-addon
+
+DESCRIPTION="Kodi's RTMP inputstream addon"
+HOMEPAGE="https://github.com/xbmc/inputstream.rtmp"
+KODI_PLUGIN_NAME="inputstream.rtmp"
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/${KODI_PLUGIN_NAME}.git"
+ EGIT_BRANCH="Matrix"
+ inherit git-r3
+ DEPEND="~media-tv/kodi-9999"
+ ;;
+*)
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/${KODI_PLUGIN_NAME}/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${KODI_PLUGIN_NAME}-${PV}-${CODENAME}"
+ DEPEND="=media-tv/kodi-19*:="
+ ;;
+esac
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+DEPEND+="
+ media-video/rtmpdump[ssl]
+ "
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ if [ -d depends ]; then rm -rf depends || die; fi
+
+ cmake_src_prepare
+}