summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-06-19 10:58:19 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-06-19 10:58:19 +0200
commit31506851fdbebd8c5af89787b2c3b11fc3e334e1 (patch)
tree551cf02a4fecb826e6f605be42492d9767db7a2a /media-plugins/hexter/hexter-1.1.1.ebuild
parentmedia-plugins/hexter: drop gtk2 support (diff)
downloadgentoo-31506851fdbebd8c5af89787b2c3b11fc3e334e1.tar.gz
gentoo-31506851fdbebd8c5af89787b2c3b11fc3e334e1.tar.bz2
gentoo-31506851fdbebd8c5af89787b2c3b11fc3e334e1.zip
media-plugins/hexter: bump to 1.1.1
Closes: https://bugs.gentoo.org/790344 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-plugins/hexter/hexter-1.1.1.ebuild')
-rw-r--r--media-plugins/hexter/hexter-1.1.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-plugins/hexter/hexter-1.1.1.ebuild b/media-plugins/hexter/hexter-1.1.1.ebuild
new file mode 100644
index 000000000000..d36ea4490cc3
--- /dev/null
+++ b/media-plugins/hexter/hexter-1.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Yamaha DX7 modeling DSSI plugin"
+HOMEPAGE="http://smbolton.com/hexter.html"
+SRC_URI="https://github.com/smbolton/${PN}/releases/download/version_${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="readline"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ media-libs/alsa-lib
+ media-libs/dssi
+ media-libs/liblo
+ readline? (
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ )
+"
+DEPEND="${RDEPEND}
+ media-libs/ladspa-sdk
+"
+
+src_configure() {
+ PKG_CONFIG=pkg-config \
+ econf --without-gtk2 \
+ $(use_with readline textui)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}