summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-10 12:27:57 +0000
committerSam James <sam@gentoo.org>2024-01-10 12:32:38 +0000
commitffe7db9fea449121418607737c320c312bebb7f9 (patch)
tree741fe217b83503e2af00c7e42368b63f8ed8a3ab /media-libs
parentmedia-libs/opencv: drop 4.8.1 (diff)
downloadgentoo-ffe7db9fea449121418607737c320c312bebb7f9.tar.gz
gentoo-ffe7db9fea449121418607737c320c312bebb7f9.tar.bz2
gentoo-ffe7db9fea449121418607737c320c312bebb7f9.zip
media-libs/opencv: filter LTO
Clearly unsafe, see e.g. https://github.com/opencv/opencv/issues/19020 too. Closes: https://bugs.gentoo.org/919101 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/opencv/opencv-4.8.1-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-libs/opencv/opencv-4.8.1-r1.ebuild b/media-libs/opencv/opencv-4.8.1-r1.ebuild
index 2ac1b3b9fcc5..643ae918665e 100644
--- a/media-libs/opencv/opencv-4.8.1-r1.ebuild
+++ b/media-libs/opencv/opencv-4.8.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cuda java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
+inherit cuda java-pkg-opt-2 java-ant-2 cmake-multilib flag-o-matic python-r1 toolchain-funcs
DESCRIPTION="A collection of algorithms and sample code for various computer vision problems"
HOMEPAGE="https://opencv.org"
@@ -351,6 +351,9 @@ src_prepare() {
}
multilib_src_configure() {
+ # bug #919101 and https://github.com/opencv/opencv/issues/19020
+ filter-lto
+
# please dont sort here, order is the same as in CMakeLists.txt
local mycmakeargs=(
-DMIN_VER_CMAKE=3.26
@@ -484,7 +487,6 @@ multilib_src_configure() {
-DENABLE_INSTRUMENTATION=OFF
-DGENERATE_ABI_DESCRIPTOR=OFF
-DDOWNLOAD_EXTERNAL_TEST_DATA=OFF
- # -DENABLE_LTO=$(usex lto)
# ===================================================
# things we want to be hard off or not yet figured out
# ===================================================