summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-09-05 14:11:01 +0200
committerDavid Seifert <soap@gentoo.org>2021-09-05 14:11:01 +0200
commit51d5e53f39fb2391f91dcf869db25b80b3837957 (patch)
tree5cd49adbd1a46eea6942fa53a9df1928aac8fbf7 /media-libs/libsamplerate
parentmedia-libs/libsamplerate: add 0.2.2 (diff)
downloadgentoo-51d5e53f39fb2391f91dcf869db25b80b3837957.tar.gz
gentoo-51d5e53f39fb2391f91dcf869db25b80b3837957.tar.bz2
gentoo-51d5e53f39fb2391f91dcf869db25b80b3837957.zip
media-libs/libsamplerate: update EAPI 7 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-libs/libsamplerate')
-rw-r--r--media-libs/libsamplerate/libsamplerate-9999.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/media-libs/libsamplerate/libsamplerate-9999.ebuild b/media-libs/libsamplerate/libsamplerate-9999.ebuild
index f754eb4667e5..698fa623a51a 100644
--- a/media-libs/libsamplerate/libsamplerate-9999.ebuild
+++ b/media-libs/libsamplerate/libsamplerate-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit multilib-minimal
@@ -12,7 +12,7 @@ if [[ ${PV} == *9999 ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/libsndfile/libsamplerate.git"
else
- SRC_URI="https://github.com/libsndfile/libsamplerate/releases/download/${PV}/${P}.tar.bz2"
+ SRC_URI="https://github.com/libsndfile/libsamplerate/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
fi
@@ -38,7 +38,6 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
- --disable-static \
$(use_enable test alsa) \
$(use_enable test fftw) \
$(use_enable test sndfile)