summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-17 03:56:38 +0000
committerSam James <sam@gentoo.org>2024-03-17 03:56:38 +0000
commita1e6a1e46d905e7bf728bb8ecfed0f342f460ae6 (patch)
tree83c9d71110b9419641543e5b4b292047a6c76f45 /media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild
parentdev-ruby/ruby-gtk3: fix modern C issue (diff)
downloadgentoo-a1e6a1e46d905e7bf728bb8ecfed0f342f460ae6.tar.gz
gentoo-a1e6a1e46d905e7bf728bb8ecfed0f342f460ae6.tar.bz2
gentoo-a1e6a1e46d905e7bf728bb8ecfed0f342f460ae6.zip
media-libs/libfishsound: fix modern C issue
Closes: https://bugs.gentoo.org/883393 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild')
-rw-r--r--media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild b/media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..174d912e442b
--- /dev/null
+++ b/media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple programming interface to decode and encode audio with vorbis or speex"
+HOMEPAGE="https://www.xiph.org/fishsound/"
+SRC_URI="https://downloads.xiph.org/releases/libfishsound/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac speex"
+
+RDEPEND="
+ media-libs/libogg
+ media-libs/libvorbis
+ flac? ( media-libs/flac:= )
+ speex? ( media-libs/speex )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+# bug #395153
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pc.patch
+ "${FILESDIR}"/${PN}-1.0.0-c99.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's:doxygen:doxygen-dummy:' \
+ configure || die
+}
+
+src_configure() {
+ local myconf="--disable-static"
+ use flac || myconf="${myconf} --disable-flac"
+ use speex || myconf="${myconf} --disable-speex"
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir="${D}/usr/share/doc/${PF}" install
+ dodoc AUTHORS ChangeLog README
+ find "${ED}" -name '*.la' -delete || die
+}