summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-02 00:06:53 +0000
committerSam James <sam@gentoo.org>2024-02-02 00:06:53 +0000
commit6d3e8e731cc4f8c341762c5d15569ae19cf4d471 (patch)
treeaa64fd5d81f788bd0c51716cf90b4586e3b849a7 /media-libs/libaom
parentsys-kernel/vanilla-sources: mark >=6.7 as -ia64 explicitly (diff)
downloadgentoo-6d3e8e731cc4f8c341762c5d15569ae19cf4d471.tar.gz
gentoo-6d3e8e731cc4f8c341762c5d15569ae19cf4d471.tar.bz2
gentoo-6d3e8e731cc4f8c341762c5d15569ae19cf4d471.zip
media-libs/libaom: build without asserts by default
Both to follow upstream recommendations (see bug #921438 -- I did also have a better source for this than the README but I can't find it now, or maybe it's changed in the meantime), but also to avoid asserts firing during daily use which don't seem to be bothering anybody upstream (bug #914614). Not ideal but it's been reported already and went nowhere. Closes: https://bugs.gentoo.org/914614 Closes: https://bugs.gentoo.org/921438 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/libaom')
-rw-r--r--media-libs/libaom/libaom-3.8.0-r1.ebuild148
1 files changed, 148 insertions, 0 deletions
diff --git a/media-libs/libaom/libaom-3.8.0-r1.ebuild b/media-libs/libaom/libaom-3.8.0-r1.ebuild
new file mode 100644
index 000000000000..19cc803b77f6
--- /dev/null
+++ b/media-libs/libaom/libaom-3.8.0-r1.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake-multilib flag-o-matic python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
+else
+ # To update test data tarball, follow these steps:
+ # 1. Clone the upstream repo and check out the relevant tag,
+ # or download the release tarball
+ # 2. Regular cmake configure (options don't matter here):
+ # cd build && cmake ..
+ # 3. Set LIBAOM_TEST_DATA_PATH to the directory you want and
+ # run the "make testdata" target:
+ # LIBAOM_TEST_DATA_PATH=../libaom-3.7.1-testdata make testdata
+ # This will download the test data from the internet.
+ # 4. Create a tarball out of that directory.
+ # cd .. && tar cvaf libaom-3.7.1-testdata.tar.xz libaom-3.7.1-testdata
+ SRC_URI="
+ https://storage.googleapis.com/aom-releases/${P}.tar.gz
+ test? ( https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-testdata.tar.xz )
+ "
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="Alliance for Open Media AV1 Codec SDK"
+HOMEPAGE="https://aomedia.org https://aomedia.googlesource.com/aom/"
+
+LICENSE="BSD-2"
+SLOT="0/3"
+IUSE="big-endian debug doc +examples test"
+IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3"
+IUSE="${IUSE} cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
+IUSE="${IUSE} cpu_flags_arm_crc32 cpu_flags_arm_neon cpu_flags_ppc_vsx"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
+ cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
+"
+
+BDEPEND="${PYTHON_DEPS}
+ dev-lang/perl
+ abi_x86_32? ( dev-lang/yasm )
+ abi_x86_64? ( dev-lang/yasm )
+ abi_x86_x32? ( dev-lang/yasm )
+ doc? ( app-text/doxygen )
+"
+
+# The PATENTS file is required to be distributed with this package, bug #682214
+DOCS=( PATENTS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4.0-posix-c-source-ftello.patch
+ "${FILESDIR}"/${PN}-3.7.0-allow-fortify-source.patch
+)
+
+multilib_src_configure() {
+ # Follow upstream recommendations in README (bug #921438) and avoid
+ # asserts during common use (bug #914614).
+ append-cppflags $(usex debug '-UNDEBUG' '-DNDEBUG')
+
+ local mycmakeargs=(
+ -DENABLE_CCACHE=OFF
+ -DENABLE_DOCS=$(multilib_native_usex doc ON OFF)
+ -DENABLE_EXAMPLES=$(multilib_native_usex examples ON OFF)
+ -DENABLE_NASM=OFF
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_TOOLS=ON
+ -DENABLE_WERROR=OFF
+ # https://bugs.chromium.org/p/aomedia/issues/detail?id=3487 shows
+ # that big endian detection doesn't really work otherwise.
+ -DCONFIG_BIG_ENDIAN=$(usex big-endian 1 0)
+
+ # Needs libjxl, currently unpackaged.
+ -DCONFIG_TUNE_BUTTERAUGLI=0
+
+ # arm
+ -DENABLE_NEON=$(usex cpu_flags_arm_neon ON OFF)
+ -DENABLE_ARM_CRC32=$(usex cpu_flags_arm_crc32 ON OFF)
+ # bug #917277
+ -DENABLE_NEON_DOTPROD=OFF
+ # bug #917278
+ -DENABLE_NEON_I8MM=OFF
+ # bug #920474
+ -DENABLE_SVE=OFF
+
+ # mips
+ # ENABLE_DSPR2 / ENABLE_MSA for mips
+
+ # amd64
+ -DENABLE_MMX=$(usex cpu_flags_x86_mmx ON OFF)
+ -DENABLE_SSE=$(usex cpu_flags_x86_sse ON OFF)
+ -DENABLE_SSE2=$(usex cpu_flags_x86_sse2 ON OFF)
+ -DENABLE_SSE3=$(usex cpu_flags_x86_sse3 ON OFF)
+ -DENABLE_SSSE3=$(usex cpu_flags_x86_ssse3 ON OFF)
+ -DENABLE_SSE4_1=$(usex cpu_flags_x86_sse4_1 ON OFF)
+ -DENABLE_SSE4_2=$(usex cpu_flags_x86_sse4_2 ON OFF)
+ -DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
+ -DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
+
+ # ppc
+ -DENABLE_VSX=$(usex cpu_flags_ppc_vsx ON OFF)
+ )
+
+ # For 32-bit multilib builds, force some intrinsics on to work around
+ # bug #816027. libaom seems to do runtime detection for some targets
+ # at least, so this isn't an issue.
+ if ! multilib_is_native_abi && use amd64 ; then
+ mycmakeargs+=(
+ -DENABLE_SSE3=ON
+ -DENABLE_SSSE3=ON
+ )
+ fi
+
+ # On ARM32-on-ARM64, things end up failing if NEON is off, bug #835456
+ # Just force generic, given it's a niche situation.
+ # TODO: could try forcing armv7 or similar?
+ if use arm && ! use cpu_flags_arm_neon && [[ $(uname -p) == "aarch64" ]] ; then
+ ewarn "Forcing generic for arm32-on-arm64 build (bug #835456)"
+ mycmakeargs+=(
+ -DAOM_TARGET_CPU=generic
+ )
+ fi
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ LIBAOM_TEST_DATA_PATH="${WORKDIR}/${P}-testdata" "${BUILD_DIR}"/test_libaom || die
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi && use doc ; then
+ local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ fi
+
+ cmake_src_install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
+}