summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/glpng
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/glpng')
-rw-r--r--media-libs/glpng/Manifest2
-rw-r--r--media-libs/glpng/files/glpng-1.45-libpng15.patch40
-rw-r--r--media-libs/glpng/glpng-1.45-r1.ebuild30
-rw-r--r--media-libs/glpng/glpng-1.46-r1.ebuild28
-rw-r--r--media-libs/glpng/metadata.xml9
5 files changed, 109 insertions, 0 deletions
diff --git a/media-libs/glpng/Manifest b/media-libs/glpng/Manifest
new file mode 100644
index 000000000000..9dc535d26c0e
--- /dev/null
+++ b/media-libs/glpng/Manifest
@@ -0,0 +1,2 @@
+DIST glpng-1.45.tar.bz2 64426 SHA256 a002aa60f460b0f363267d10c79c730b9dba4c834d0ee43eac15460c2e05f2e8 SHA512 002d6ca05c603d2728454c4daafddca3be23afabd17181d69d7993734306e71c65cf4562e6598ca09b5a50e0c94ecbb0e3b1622788d50af53f54abfae5904747 WHIRLPOOL 643c3dc658068c397fdfe4002a7e0f098c79dbd74189926b4fbbcad70302fe666cec170169562bf776c022894c5910685c247474d8fa37196eef887ccc020892
+DIST glpng-1.46.tar.gz 41024 SHA256 4a3e489deca733524780470c4fb89806e354515b541efb58d44f2e11936dc39e SHA512 82fbd6154a0ca16102b4c31f7fbd907cf8c18b20c1693c60f8dcdd1fe42ebe579f98da2b36c00fc080b2880c720e8099dac0d460a8de1b2bf1145abbf05a20ae WHIRLPOOL 1bad8a51377fed856cfba3309ae7c4069517d31d372b297f3f8d60616e561d3cc042751ff50bb11aaac73d27198b47c4d428139ce4f27d5f38dd4d7a80678b78
diff --git a/media-libs/glpng/files/glpng-1.45-libpng15.patch b/media-libs/glpng/files/glpng-1.45-libpng15.patch
new file mode 100644
index 000000000000..06a3e9e0f508
--- /dev/null
+++ b/media-libs/glpng/files/glpng-1.45-libpng15.patch
@@ -0,0 +1,40 @@
+--- include/GL/glpng.h
++++ include/GL/glpng.h
+@@ -57,7 +57,7 @@
+ #define PNG_SIMPLEMIPMAP PNG_SIMPLEMIPMAPS
+
+ /* Transparency parameters */
+-#define PNG_CALLBACK -3 /* Call the callback function to generate alpha */
++#define PNG_CALLBACKT -3 /* Call the callback function to generate alpha */
+ #define PNG_ALPHA -2 /* Use alpha channel in PNG file, if there is one */
+ #define PNG_SOLID -1 /* No transparency */
+ #define PNG_STENCIL 0 /* Sets alpha to 0 for r=g=b=0, 1 otherwise */
+--- src/glpng.c
++++ src/glpng.c
+@@ -276,7 +276,7 @@
+ endinfo = png_create_info_struct(png);
+
+ // DH: added following lines
+- if (setjmp(png->jmpbuf))
++ if (setjmp(png_jmpbuf(png)))
+ {
+ png_destroy_read_struct(&png, &info, &endinfo);
+ return 0;
+@@ -380,7 +380,7 @@
+ endinfo = png_create_info_struct(png);
+
+ // DH: added following lines
+- if (setjmp(png->jmpbuf))
++ if (setjmp(png_jmpbuf(png)))
+ {
+ png_destroy_read_struct(&png, &info, &endinfo);
+ return 0;
+@@ -559,7 +559,7 @@
+ #define ALPHA *q
+
+ switch (trans) {
+- case PNG_CALLBACK:
++ case PNG_CALLBACKT:
+ FORSTART
+ ALPHA = AlphaCallback((unsigned char) r, (unsigned char) g, (unsigned char) b);
+ FOREND
diff --git a/media-libs/glpng/glpng-1.45-r1.ebuild b/media-libs/glpng/glpng-1.45-r1.ebuild
new file mode 100644
index 000000000000..235fd5672232
--- /dev/null
+++ b/media-libs/glpng/glpng-1.45-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils eutils multilib
+
+DESCRIPTION="An OpenGL png image library"
+HOMEPAGE="http://www.fifi.org/doc/libglpng-dev/glpng.html"
+SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libpng
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+
+ # fix libdir placement
+ sed -i \
+ -e "s:CMAKE_INSTALL_LIBDIR lib:CMAKE_INSTALL_LIBDIR $(get_libdir):g"\
+ CMakeLists.txt || die
+}
diff --git a/media-libs/glpng/glpng-1.46-r1.ebuild b/media-libs/glpng/glpng-1.46-r1.ebuild
new file mode 100644
index 000000000000..88d70343bff0
--- /dev/null
+++ b/media-libs/glpng/glpng-1.46-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-multilib
+
+DESCRIPTION="An OpenGL PNG image library"
+HOMEPAGE="http://repo.or.cz/w/glpng.git"
+SRC_URI="http://repo.or.cz/w/glpng.git/snapshot/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/opengl[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]"
+DEPEND=${RDEPEND}
+
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ local mycmakeargs=( "$(cmake-utils_use_build static-libs STATIC_LIBS)" )
+ cmake-multilib_src_configure
+}
diff --git a/media-libs/glpng/metadata.xml b/media-libs/glpng/metadata.xml
new file mode 100644
index 000000000000..d30d9a3bd0f4
--- /dev/null
+++ b/media-libs/glpng/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <longdescription>This is a library for OpenGL to load PNG graphics files as an OpenGL texture as easily as possible. It also has a number of options for generating the alpha channel and mipmaps.</longdescription>
+</pkgmetadata>