summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-05 13:26:45 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-05 13:26:59 +0000
commit385dfbc785aed31726688504959be6e20896716c (patch)
treeebb1990b04f4f4eb95df16ce1570d6bbb29701f6 /media-libs/gegl
parentmedia-plugins/vdr-burn: version bump (diff)
downloadgentoo-385dfbc785aed31726688504959be6e20896716c.tar.gz
gentoo-385dfbc785aed31726688504959be6e20896716c.tar.bz2
gentoo-385dfbc785aed31726688504959be6e20896716c.zip
media-libs/gegl: add missing -lm to tests, bug #639986
The change fixes underlinking on ia64: ``` gnu/bin/ld: buffer-test.o: undefined reference to symbol 'floor@@GLIBC_2.2' /usr/lib/gcc/ia64-unknown-linux-gnu/9.2.0/../../../../ia64-unknown-linux-gnu/bin/ld: /lib/libm.so.6.1: error adding symbols: DSO missing from command line ``` Closes: https://bugs.gentoo.org/639986 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'media-libs/gegl')
-rw-r--r--media-libs/gegl/files/gegl-0.2.0-underlinking.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/media-libs/gegl/files/gegl-0.2.0-underlinking.patch b/media-libs/gegl/files/gegl-0.2.0-underlinking.patch
index 53f29c49da7d..00e936ce68ea 100644
--- a/media-libs/gegl/files/gegl-0.2.0-underlinking.patch
+++ b/media-libs/gegl/files/gegl-0.2.0-underlinking.patch
@@ -47,6 +47,19 @@ index 8f1077d..4dd3845 100644
noinst_PROGRAMS = introspect operation_reference img_cmp
+diff --git a/tests/buffer/Makefile.am b/tests/buffer/Makefile.am
+index d62ce71..0a4df53 100644
+--- a/tests/buffer/Makefile.am
++++ b/tests/buffer/Makefile.am
+@@ -30,7 +30,7 @@ AM_CFLAGS = $(DEP_CFLAGS) $(BABL_CFLAGS)
+
+ buffer_test_LDADD = \
+ $(top_builddir)/gegl/libgegl-$(GEGL_API_VERSION).la \
+- $(DEP_LIBS) $(BABL_LIBS)
++ $(DEP_LIBS) $(BABL_LIBS) $(MATH_LIB)
+
+
+ # Our custom target rules
--
2.12.2