summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-12-07 07:39:14 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-12-07 07:47:00 +0100
commitf1aff2fc5a7de3d33d6c1867d04085d00df56718 (patch)
treeceae0ea2fb9879c7658c099c058ceb52d3a2d691 /media-libs/alsa-lib
parentdev-python/tomli-w: Added ~mips to KEYWORDS (diff)
downloadgentoo-f1aff2fc5a7de3d33d6c1867d04085d00df56718.tar.gz
gentoo-f1aff2fc5a7de3d33d6c1867d04085d00df56718.tar.bz2
gentoo-f1aff2fc5a7de3d33d6c1867d04085d00df56718.zip
media-libs/alsa-lib: Bump to version 1.2.6
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/Manifest1
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.2.6.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/Manifest b/media-libs/alsa-lib/Manifest
index 2f2cda5dd263..baae0ac54fbd 100644
--- a/media-libs/alsa-lib/Manifest
+++ b/media-libs/alsa-lib/Manifest
@@ -1,2 +1,3 @@
DIST alsa-lib-1.2.4.tar.bz2 1044405 BLAKE2B e1d5d9afe21dac693645274ae4ec8a607c9fcc9915ba4ebccfdb539d44b9353ba07529e2c8eaca119884b926d4467285313c945c9015a788101fe532064442db SHA512 12086952dc8f16f1cb6946517858e17b1c3276aeda9ff5703a84bb38aa78eb4c4e9cb4485c5b3f21f174fdbd976b3bcbbc481e85cb2460652858490df51ae844
DIST alsa-lib-1.2.5.1.tar.bz2 1069073 BLAKE2B 5464cc7f263bdf7b10aa7e1f542ad6dbc55bf300156fd1bded00375c41a518d4b14f96e28eb1c60a6ce7cc6e27da4b2e8598cd867f15417f260fc23513f93e11 SHA512 01998ffa449e925ff552c13aea47f9540903afdc533086067c78dcaba4d239c347180d3d28bb0000e6d19b7779c7249fcc77a30057930ca22d18ba55e163fa1c
+DIST alsa-lib-1.2.6.tar.bz2 1079598 BLAKE2B 84a7a20fbea4025f2ac08acefa3a9ea9d2737585c5d5f09c8df3b5ccb998eaa09a7ec16a019a40c4d3e3e4b5209b961f9da23ec57c0bb9824bade9a3a0dd4350 SHA512 ae95718813abf62811fe44c6df2a8de5a1227da4b022c4dd97dd8e7c1001f48307ba36bf04208bdbe24e8a8eebf4ed5a59f40ee6750dcbe976678071c3f2f5b7
diff --git a/media-libs/alsa-lib/alsa-lib-1.2.6.ebuild b/media-libs/alsa-lib/alsa-lib-1.2.6.ebuild
new file mode 100644
index 000000000000..1b9c1819ad93
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.2.6.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit autotools multilib-minimal python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="https://alsa-project.org/wiki/Main_Page"
+if [[ ${PV} == *_p* ]] ; then
+ # Please set correct commit ID for a snapshot release!!!
+ COMMIT="abe805ed6c7f38e48002e575535afd1f673b9bcd"
+ SRC_URI="https://git.alsa-project.org/?p=${PN}.git;a=snapshot;h=${COMMIT};sf=tgz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT:0:7}
+else
+ # TODO: Upstream does publish .sig files, so someone could implement verify-sig ;)
+ SRC_URI="https://www.alsa-project.org/files/pub/lib/${P}.tar.bz2"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alisp debug doc elibc_uclibc python +thread-safety"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+BDEPEND="doc? ( >=app-doc/doxygen-1.2.6 )"
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ media-libs/alsa-topology-conf
+ media-libs/alsa-ucm-conf
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.6-missing_files.patch" # bug #652422
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
+ # https://bugs.gentoo.org/509886
+ if use elibc_uclibc ; then
+ sed -i -e 's:oldapi queue_timer:queue_timer:' test/Makefile.am || die
+ fi
+ # https://bugs.gentoo.org/545950
+ sed -i -e '5s:^$:\nAM_CPPFLAGS = -I$(top_srcdir)/include:' test/lsb/Makefile.am || die
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-maintainer-mode
+ --disable-resmgr
+ --enable-aload
+ --enable-rawmidi
+ --enable-seq
+ --enable-shared
+ # enable Python only on final ABI
+ $(multilib_native_use_enable python)
+ $(use_enable alisp)
+ $(use_enable thread-safety)
+ $(use_with debug)
+ $(usex elibc_uclibc --without-versioned '')
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ emake doc
+ grep -FZrl "${S}" doc/doxygen/html | \
+ xargs -0 sed -i -e "s:${S}::" || die
+ fi
+}
+
+multilib_src_install() {
+ multilib_is_native_abi && use doc && local HTML_DOCS=( doc/doxygen/html/. )
+ default
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f \( -name '*.a' -o -name '*.la' \) -delete || die
+ dodoc ChangeLog doc/asoundrc.txt NOTES TODO
+}