summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-06-13 16:40:23 +0200
committerUlrich Müller <ulm@gentoo.org>2022-06-13 16:46:24 +0200
commitc0a45c1936961b948204e1563592d345f6412e2c (patch)
tree9d3a42e942fd46b18ba7b8bc832e655ac0346d34 /media-gfx
parentlicenses: License for media-gfx/jpeg2ps (diff)
downloadgentoo-c0a45c1936961b948204e1563592d345f6412e2c.tar.gz
gentoo-c0a45c1936961b948204e1563592d345f6412e2c.tar.bz2
gentoo-c0a45c1936961b948204e1563592d345f6412e2c.zip
media-gfx/jpeg2ps: Update SRC_URI
The manifest checksum of the previous .tar.gz distfile no longer matches and it cannot be unpacked any more. Switch to the .zip distfile. Bump ebuild to EAPI 8. Update LICENSE and RESTRICT. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/jpeg2ps/Manifest1
-rw-r--r--media-gfx/jpeg2ps/jpeg2ps-1.9-r2.ebuild5
-rw-r--r--media-gfx/jpeg2ps/jpeg2ps-1.9-r3.ebuild50
3 files changed, 54 insertions, 2 deletions
diff --git a/media-gfx/jpeg2ps/Manifest b/media-gfx/jpeg2ps/Manifest
index 8883824b23c7..5f96aee29956 100644
--- a/media-gfx/jpeg2ps/Manifest
+++ b/media-gfx/jpeg2ps/Manifest
@@ -1 +1,2 @@
DIST jpeg2ps-1.9.tar.gz 67105 BLAKE2B 68df39df75525db872c683de7b0ed3e64317ea18a54d51fb478c3e51b26522a97081e6953e5ad92f7a6023829dc5fbc5e1e288f2041e76bdecf0b6ef035d1234 SHA512 babc6183db2c95d0bcfba3d34f924bd2a37d0a566bf684f3af3955b8b3978cd4b94b10e94f366aec641988258476f84ce730e4da43f2bb0a836e81da4892ad3c
+DIST jpeg2ps-1.9.zip 97279 BLAKE2B 59c8a1b4d90e43d87e33afde1e742884b62371152672beae9c0f3b25a7abe3fc9c19f8b14a4780b1c0f7efdc2ebdf545ee12446d7aa89d19c94bb65e5ce323eb SHA512 7a8405b0b5cffaf3e85cad1dc236fdd951b6c7922cf15ac2ced619766db1fff6babb651747e9173a98324d513bde2f23402e6108784d02af882a25748b04aef3
diff --git a/media-gfx/jpeg2ps/jpeg2ps-1.9-r2.ebuild b/media-gfx/jpeg2ps/jpeg2ps-1.9-r2.ebuild
index 9a25a5e30b7d..0e8f60a2c007 100644
--- a/media-gfx/jpeg2ps/jpeg2ps-1.9-r2.ebuild
+++ b/media-gfx/jpeg2ps/jpeg2ps-1.9-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,10 +9,11 @@ DESCRIPTION="Convert JPEG images to Postscript using a wrapper"
HOMEPAGE="https://web.archive.org/web/20131003144811/http://www.pdflib.com/download/free-software/jpeg2ps/"
SRC_URI="https://web.archive.org/web/20131003165952/http://www.pdflib.com/fileadmin/pdflib/products/more/${PN}/${P}.tar.gz"
-LICENSE="free-noncomm"
+LICENSE="jpeg2ps"
SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="metric"
+RESTRICT="mirror"
PATCHES=("${FILESDIR}"/${P}-include.diff)
diff --git a/media-gfx/jpeg2ps/jpeg2ps-1.9-r3.ebuild b/media-gfx/jpeg2ps/jpeg2ps-1.9-r3.ebuild
new file mode 100644
index 000000000000..cb7c6862a06e
--- /dev/null
+++ b/media-gfx/jpeg2ps/jpeg2ps-1.9-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edos2unix toolchain-funcs readme.gentoo-r1
+
+DESCRIPTION="Convert JPEG images to Postscript using a wrapper"
+HOMEPAGE="https://web.archive.org/web/20131003144811/http://www.pdflib.com/download/free-software/jpeg2ps/"
+SRC_URI="https://web.archive.org/web/20131003165952/http://www.pdflib.com/fileadmin/pdflib/products/more/${PN}/${P}.zip"
+
+LICENSE="jpeg2ps"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="metric"
+RESTRICT="mirror"
+
+BDEPEND="app-arch/unzip"
+
+PATCHES=("${FILESDIR}"/${P}-include.diff)
+
+src_prepare() {
+ edos2unix Makefile *.c *.h *.1 *.txt
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ CFLAGS="-c ${CFLAGS} $(usev metric -DA4)" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin jpeg2ps
+ doman jpeg2ps.1
+ dodoc jpeg2ps.txt
+
+ local size1=letter size2=A4
+ use metric && size1=A4 size2=letter
+ DOC_CONTENTS="By default, this installation of jpeg2ps will generate
+ ${size1} size output. You can force ${size2} output with
+ \n\tjpeg2ps -p ${size2} file.jpg > file.ps"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}