summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-08 02:14:59 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-08 02:36:00 -0400
commit7a097d121d46c7588d136bb0f0a84da621d58f6e (patch)
treee3d714af839594bbec5042c34181108407ad0e3f /media-gfx
parentwww-client/firefox-bin: fix esr's desktop file, another try (diff)
downloadgentoo-7a097d121d46c7588d136bb0f0a84da621d58f6e.tar.gz
gentoo-7a097d121d46c7588d136bb0f0a84da621d58f6e.tar.bz2
gentoo-7a097d121d46c7588d136bb0f0a84da621d58f6e.zip
media-gfx/ueberzugpp: add 2.9.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/ueberzugpp/Manifest1
-rw-r--r--media-gfx/ueberzugpp/ueberzugpp-2.9.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/media-gfx/ueberzugpp/Manifest b/media-gfx/ueberzugpp/Manifest
index fe565f147a40..f85b174ef9ec 100644
--- a/media-gfx/ueberzugpp/Manifest
+++ b/media-gfx/ueberzugpp/Manifest
@@ -1 +1,2 @@
DIST ueberzugpp-2.8.9.tar.gz 58717 BLAKE2B 5f7aaf1f3fafe1d512d9c284dba1e34d5b214f18ab06b8c02896f726cf09eae6c2482210d8cd2ba7d4909c91685e2bfdfd0fd07702cc18b2a122e489f1fe2494 SHA512 37ddc89a5e769815a0b86599ee81cf8024b7dcce2f7129c6b49210ac99749c5cb76b787a8547fa8d246ce3eee24c8d972852e6d18db617bbed7125569bee2c1a
+DIST ueberzugpp-2.9.0.tar.gz 65829 BLAKE2B 55498b49077e2a85546d251efd082b67f811513d87064bb907e29ec5f4b72a22ed9c85be7296a5a9594fe1c520041c61b458acc96ac6f187106079b3429ace37 SHA512 4b21565a8ed2874f966fd5618fc043932dd9b310812be0e36b9c6548af11b773ca2d2977458ddd50db70e0fbe2d603c408480c5982e9538220c8c7173d30e6b2
diff --git a/media-gfx/ueberzugpp/ueberzugpp-2.9.0.ebuild b/media-gfx/ueberzugpp/ueberzugpp-2.9.0.ebuild
new file mode 100644
index 000000000000..828290c2ec13
--- /dev/null
+++ b/media-gfx/ueberzugpp/ueberzugpp-2.9.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Drop in replacement for ueberzug written in C++"
+HOMEPAGE="https://github.com/jstkdng/ueberzugpp/"
+SRC_URI="
+ https://github.com/jstkdng/ueberzugpp/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X opencv opengl wayland xcb-errors"
+REQUIRED_USE="xcb-errors? ( X )"
+
+RDEPEND="
+ dev-cpp/tbb:=
+ dev-libs/glib:2
+ dev-libs/libfmt:=
+ dev-libs/openssl:=
+ dev-libs/spdlog:=
+ media-gfx/chafa
+ media-libs/libsixel
+ media-libs/vips:=
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-image
+ xcb-errors? ( x11-libs/xcb-util-errors )
+ )
+ opencv? ( media-libs/opencv:= )
+ opengl? ( media-libs/libglvnd )
+ wayland? ( dev-libs/wayland )
+ !media-gfx/ueberzug
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/cli11
+ dev-cpp/ms-gsl
+ dev-cpp/nlohmann_json
+ X? ( x11-base/xorg-proto )
+ wayland? ( dev-libs/wayland-protocols )
+"
+BDEPEND="
+ wayland? (
+ dev-util/wayland-scanner
+ kde-frameworks/extra-cmake-modules
+ )
+"
+
+src_configure() {
+ # TODO?: wayfire plugin is skipped for now (needs wlroots which is
+ # likely to be messier), but could be handled if there is a demand
+
+ local mycmakeargs=(
+ -DENABLE_OPENCV=$(usex opencv)
+ -DENABLE_OPENGL=$(usex opengl)
+ -DENABLE_TURBOBASE64=no # not packaged
+ -DENABLE_WAYLAND=$(usex wayland)
+ -DENABLE_X11=$(usex X)
+ -DENABLE_XCB_ERRORS=$(usex xcb-errors)
+ -DFETCHCONTENT_FULLY_DISCONNECTED=yes
+ )
+
+ cmake_src_configure
+}