summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/svg2rlg/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/svg2rlg/files')
-rw-r--r--media-gfx/svg2rlg/files/svg2rlg-issue-3.patch19
-rw-r--r--media-gfx/svg2rlg/files/svg2rlg-issue-6.patch47
-rw-r--r--media-gfx/svg2rlg/files/svg2rlg-issue-7.patch16
3 files changed, 82 insertions, 0 deletions
diff --git a/media-gfx/svg2rlg/files/svg2rlg-issue-3.patch b/media-gfx/svg2rlg/files/svg2rlg-issue-3.patch
new file mode 100644
index 000000000000..df70bf345aa8
--- /dev/null
+++ b/media-gfx/svg2rlg/files/svg2rlg-issue-3.patch
@@ -0,0 +1,19 @@
+commit e5aa6784a10717641bc5b6d9d77a5029f815654a
+Author: yac <yac@blesmrt.net>
+Date: Wed May 8 04:59:17 2013 +0200
+
+ fix #3
+
+ remove windows only function which is useless anyway
+
+diff --git a/svg2rlg.py b/svg2rlg.py
+index 1c5f80c..2b35c62 100644
+--- a/svg2rlg.py
++++ b/svg2rlg.py
+@@ -1574,5 +1574,3 @@ if __name__ == "__main__":
+
+ drawing = svg2rlg(source)
+ drawing.save(formats=['pdf'],outDir='.',fnRoot=name)
+-
+- os.startfile(name + '.pdf')
+\ No newline at end of file
diff --git a/media-gfx/svg2rlg/files/svg2rlg-issue-6.patch b/media-gfx/svg2rlg/files/svg2rlg-issue-6.patch
new file mode 100644
index 000000000000..6ca750e79193
--- /dev/null
+++ b/media-gfx/svg2rlg/files/svg2rlg-issue-6.patch
@@ -0,0 +1,47 @@
+commit e42661b9cd6d7b71ce5e7674ac8eff25c74db07a
+Author: yac <yac@blesmrt.net>
+Date: Wed May 8 05:00:32 2013 +0200
+
+ use entry_point fixes #6
+
+diff --git a/setup.py b/setup.py
+index 9e00fba..512fa79 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,6 +1,6 @@
+ #!/usr/bin/python
+ # -*- coding: utf-8 -*-
+-from distutils.core import setup
++from setuptools import setup
+
+ setup(
+ name = 'svg2rlg',
+@@ -12,6 +12,8 @@ setup(
+ url = 'http://code.google.com/p/svg2rlg/',
+ download_url = 'http://pypi.python.org/pypi/svg2rlg/',
+ requires = ['reportlab'],
++ entry_points = {
++ 'console_scripts': ['svg2rlg = svg2rlg:main']},
+
+ classifiers=[
+ 'Environment :: Console',
+@@ -30,4 +32,4 @@ The authors motivation was to have a more robust handling of
+ SVG files in the **rst2pdf** tool. Specific to be able to handle
+ the quirks needed to include SVG export from matplotlib.
+ '''
+-)
+\ No newline at end of file
++)
+diff --git a/svg2rlg.py b/svg2rlg.py
+index 2b35c62..cc812b2 100644
+--- a/svg2rlg.py
++++ b/svg2rlg.py
+@@ -1562,7 +1562,7 @@ def svg2rlg(filename):
+
+ return renderer.render(xml)
+
+-if __name__ == "__main__":
++def main():
+ import sys
+ import os
+
diff --git a/media-gfx/svg2rlg/files/svg2rlg-issue-7.patch b/media-gfx/svg2rlg/files/svg2rlg-issue-7.patch
new file mode 100644
index 000000000000..8145f416f804
--- /dev/null
+++ b/media-gfx/svg2rlg/files/svg2rlg-issue-7.patch
@@ -0,0 +1,16 @@
+commit c30b4f90cac69934761e44bf59a8ba8a3827d647
+Author: yac <yac@blesmrt.net>
+Date: Wed May 8 05:44:00 2013 +0200
+
+ fix #7
+
+diff --git a/svg2rlg.py b/svg2rlg.py
+index cc812b2..80d72de 100644
+--- a/svg2rlg.py
++++ b/svg2rlg.py
+@@ -1573,4 +1573,4 @@ def main():
+ name, ext = os.path.splitext(filename)
+
+ drawing = svg2rlg(source)
+- drawing.save(formats=['pdf'],outDir='.',fnRoot=name)
++ drawing.save(formats=['pdf'],outDir=os.getcwd(),fnRoot=name)