summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-04-18 21:54:16 +0200
committerDavid Seifert <soap@gentoo.org>2018-04-18 21:57:18 +0200
commit1184156dec55cc4ca0133c7b9464f63a91e2709c (patch)
treea6c64d3e346d127b12330630a934b30938f876bb /media-gfx/gozer
parentx11-misc/Xorgautoconfig: remove last rited package (diff)
downloadgentoo-1184156dec55cc4ca0133c7b9464f63a91e2709c.tar.gz
gentoo-1184156dec55cc4ca0133c7b9464f63a91e2709c.tar.bz2
gentoo-1184156dec55cc4ca0133c7b9464f63a91e2709c.zip
media-gfx/gozer: [QA] Cleanup ebuild
Package-Manager: Portage-2.3.30, Repoman-2.3.9
Diffstat (limited to 'media-gfx/gozer')
-rw-r--r--media-gfx/gozer/files/gozer-0.7-fix-build-system.patch51
-rw-r--r--media-gfx/gozer/gozer-0.7-r3.ebuild21
2 files changed, 59 insertions, 13 deletions
diff --git a/media-gfx/gozer/files/gozer-0.7-fix-build-system.patch b/media-gfx/gozer/files/gozer-0.7-fix-build-system.patch
new file mode 100644
index 000000000000..6102fe9c64c8
--- /dev/null
+++ b/media-gfx/gozer/files/gozer-0.7-fix-build-system.patch
@@ -0,0 +1,51 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -5,14 +5,9 @@
+ # A list of all the files in the current directory which can be regenerated
+ MAINTAINERCLEANFILES = Makefile.in gozer.spec
+
+-LDFLAGS = -L/usr/X11R6/lib -L/usr/lib -L/usr/local/lib
+-INCLUDES = -I/usr/X11R6/include \
+-$(X_CFLAGS) -I$(prefix)/include -I$(includedir) -I.
+-
+ man_MANS = gozer.1
+
+-docs_DATA = README AUTHORS ChangeLog TODO
+-docsdir = $(prefix)/doc/@PACKAGE@
++doc_DATA = README AUTHORS ChangeLog TODO
+
+ EXTRA_DIST = \
+ gozer.spec gozer.1 $(docs_DATA)
+--- a/src/fonts/Makefile.am
++++ b/src/fonts/Makefile.am
+@@ -8,6 +8,6 @@
+ fonts_DATA = \
+ helmetr.ttf
+
+-fontsdir=$(prefix)/share/@PACKAGE@/fonts
++fontsdir=$(prefix)/share/$(PACKAGE)/fonts
+
+ EXTRA_DIST = $(fonts_DATA)
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,15 +1,13 @@
+ # A list of all the files in the current directory which can be regenerated
+-MAINTAINERCLEANFILES = Makefile.in
++MAINTAINERCLEANFILES = Makefile.in
+
+ SUBDIRS = fonts
+
+-LDFLAGS = -L/usr/X11R6/lib
+-INCLUDES = -g -O3 -Wall -I/usr/X11R6/include \
+-$(X_CFLAGS) -I$(prefix)/include -I$(includedir) -I. \
+--DPREFIX=\""$(prefix)"\" @GIBLIB_CFLAGS@
+-LIBOBJS = @LIBOBJS@
++AM_CPPFLAGS = -Wall -I/usr/X11R6/include \
++ $(X_CFLAGS) -I$(prefix)/include -I$(includedir) -I. \
++ -DPREFIX=\""$(prefix)"\" $(GIBLIB_CFLAGS)
+
+ bin_PROGRAMS = gozer
+ gozer_SOURCES = main.c getopt.c getopt1.c getopt.h gozer.h \
+ options.c options.h debug.h utils.c utils.h imlib.c structs.h
+-gozer_LDADD = @GIBLIB_LIBS@
++gozer_LDADD = $(GIBLIB_LIBS) -L/usr/X11R6/lib
diff --git a/media-gfx/gozer/gozer-0.7-r3.ebuild b/media-gfx/gozer/gozer-0.7-r3.ebuild
index 05e8079d3ba2..64e0751606c7 100644
--- a/media-gfx/gozer/gozer-0.7-r3.ebuild
+++ b/media-gfx/gozer/gozer-0.7-r3.ebuild
@@ -14,22 +14,17 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
-DEPEND="x11-libs/libXext
- >=media-libs/giblib-1.2.1"
-RDEPEND=">=media-libs/giblib-1.2.1
+RDEPEND="
+ media-libs/giblib
media-libs/imlib2"
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libXext"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
src_prepare() {
default
- sed -i src/Makefile.am \
- -e 's|-g -O3|$(CFLAGS)|g' \
- -e '/LDFLAGS/s|=|+=|g' \
- || die "sed src/Makefile.am"
+ mv configure.{in,ac} || die
eautoreconf
}
-
-src_install() {
- emake install DESTDIR="${D}"
- rm -rf "${D}"/usr/doc || die
- dodoc TODO README AUTHORS ChangeLog
-}