summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/terminus-font/terminus-font-4.36.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/terminus-font/terminus-font-4.36.ebuild')
-rw-r--r--media-fonts/terminus-font/terminus-font-4.36.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/media-fonts/terminus-font/terminus-font-4.36.ebuild b/media-fonts/terminus-font/terminus-font-4.36.ebuild
new file mode 100644
index 000000000000..c0d1801ad3f5
--- /dev/null
+++ b/media-fonts/terminus-font/terminus-font-4.36.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils font
+
+DESCRIPTION="A clean fixed font for the console and X11"
+HOMEPAGE="http://terminus-font.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="OFL-1.1 GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="a-like-o distinct-l ru-dv +ru-g quote ru-i ru-k +psf raw-font-data +pcf"
+
+DEPEND="dev-lang/perl
+ virtual/awk
+ app-arch/gzip
+ pcf? ( x11-apps/bdftopcf )"
+RDEPEND=""
+
+FONTDIR=/usr/share/fonts/terminus
+DOCS="README README-BG AUTHORS CHANGES"
+
+pkg_setup() {
+ # Note: that pcf fonts can be loaded by freetype even if X is not installed.
+ # That's why configuration +pcf and -X is supported, bug #155783.
+ if use X && ! use pcf ; then
+ eerror "Fonts which works with Xserver are intalled only if pcf is enabled."
+ die "Either disable X use flag or enabled pcf."
+ fi
+
+ font_pkg_setup
+}
+
+src_prepare() {
+ # Upstream patches. Some of them are suggested to be applied by default
+ # dv - de NOT like latin g, but like caps greek delta
+ # ve NOT like greek beta, but like caps latin B
+ # ge - ge NOT like "mirrored" latin s, but like caps greek gamma
+ # ka - small ka NOT like minimised caps latin K, but like small latin k
+ use a-like-o && epatch "${S}"/alt/ao2.diff
+ use distinct-l && epatch "${S}"/alt/ll2.diff
+ use ru-i && epatch "${S}"/alt/ij1.diff
+ use ru-k && epatch "${S}"/alt/ka2.diff
+ use ru-dv && epatch "${S}"/alt/dv1.diff
+ use ru-g && epatch "${S}"/alt/ge2.diff
+ use quote && epatch "${S}"/alt/gq2.diff
+}
+
+src_configure() {
+ # selfwritten configure script
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --psfdir="${EPREFIX}"/usr/share/consolefonts \
+ --acmdir="${EPREFIX}"/usr/share/consoletrans \
+ --unidir="${EPREFIX}"/usr/share/consoletrans \
+ --x11dir="${EPREFIX}"/${FONTDIR} || die
+}
+
+src_compile() {
+ if use psf; then emake psf txt || die; fi
+ if use raw-font-data; then emake raw || die; fi
+ if use pcf; then emake pcf || die; fi
+}
+
+src_install() {
+ if use psf; then
+ emake DESTDIR="${D}" install-psf install-uni install-acm install-ref || die
+ fi
+ if use raw-font-data; then
+ emake DESTDIR="${D}" install.raw || die
+ fi
+ if use pcf; then
+ emake DESTDIR="${D}" install-pcf || die
+ fi
+
+ font_src_install
+}