summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-09-06 20:26:38 +0200
committerPacho Ramos <pacho@gentoo.org>2024-09-06 20:26:38 +0200
commita0e6b5943e100320c773b0852787fe425301a3b1 (patch)
tree0f99fd25299b6ce40c79627a07400f6f2c14671c /media-fonts/noto/noto-20240830.ebuild
parentprofiles/arch/mips: mask media-libs/libavif[rav1e] (diff)
downloadgentoo-a0e6b5943e100320c773b0852787fe425301a3b1.tar.gz
gentoo-a0e6b5943e100320c773b0852787fe425301a3b1.tar.bz2
gentoo-a0e6b5943e100320c773b0852787fe425301a3b1.zip
media-fonts/noto: add 20240830
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-fonts/noto/noto-20240830.ebuild')
-rw-r--r--media-fonts/noto/noto-20240830.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-fonts/noto/noto-20240830.ebuild b/media-fonts/noto/noto-20240830.ebuild
new file mode 100644
index 000000000000..73e020cb6c44
--- /dev/null
+++ b/media-fonts/noto/noto-20240830.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit font
+
+DESCRIPTION="Google's font family that aims to support all the world's languages"
+HOMEPAGE="https://fonts.google.com/noto https://github.com/notofonts/notofonts.github.io"
+
+COMMIT="eeb71fdda20300eb0891badeed5e64850e2cbc64"
+SRC_URI="https://github.com/notofonts/notofonts.github.io/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/notofonts.github.io-${COMMIT}"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+# Extra allows to optionally reduce disk usage even returning to tofu
+# issue as described in https://fonts.google.com/noto
+IUSE="cjk +extra"
+
+RDEPEND="cjk? ( media-fonts/noto-cjk )"
+
+RESTRICT="binchecks strip"
+
+FONT_SUFFIX="ttf"
+FONT_CONF=(
+ # From ArchLinux
+ "${FILESDIR}/66-noto-serif.conf"
+ "${FILESDIR}/66-noto-mono.conf"
+ "${FILESDIR}/66-noto-sans.conf"
+)
+
+src_install() {
+ mkdir install-hinted || die
+ mv fonts/*/hinted/ttf/*.tt[fc] install-hinted/. || die
+
+ FONT_S="${S}/install-hinted/" font_src_install
+
+ # Allow to drop some fonts optionally for people that want to save
+ # disk space. Following ArchLinux options.
+ use extra || rm -rf "${ED}"/usr/share/fonts/noto/Noto*{Condensed,SemiBold,Extra}*.tt[f,c]
+}