summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-10-26 21:10:05 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-27 12:24:19 +0100
commit36ef6982bac289a6565459cc29339ba506f02cdf (patch)
tree94bfad419f5ca594dc6ffa57914e3eb16927ab54 /media-fonts/glass-tty-vt220/glass-tty-vt220-001.3-r2.ebuild
parentapp-text/zathura-pdf-mupdf: fix build (diff)
downloadgentoo-36ef6982bac289a6565459cc29339ba506f02cdf.tar.gz
gentoo-36ef6982bac289a6565459cc29339ba506f02cdf.tar.bz2
gentoo-36ef6982bac289a6565459cc29339ba506f02cdf.zip
media-fonts/glass-tty-vt220: update font cache automatically
Since pkg_postinst is custom definied, the font cache is not updated after installation. This can lead to access violations on other packages, which try to do this. Closes: https://bugs.gentoo.org/698526 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/13453 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-fonts/glass-tty-vt220/glass-tty-vt220-001.3-r2.ebuild')
-rw-r--r--media-fonts/glass-tty-vt220/glass-tty-vt220-001.3-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-fonts/glass-tty-vt220/glass-tty-vt220-001.3-r2.ebuild b/media-fonts/glass-tty-vt220/glass-tty-vt220-001.3-r2.ebuild
new file mode 100644
index 000000000000..7a257a419b64
--- /dev/null
+++ b/media-fonts/glass-tty-vt220/glass-tty-vt220-001.3-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="8d5bcafe971ee94df4aa20317f197d407df672e9"
+MY_PN="glasstty"
+
+inherit font
+
+DESCRIPTION="Hacking with Style: TrueType VT220 Font"
+HOMEPAGE="
+ http://sensi.org/~svo/glasstty/
+ https://github.com/svofski/glasstty
+"
+SRC_URI="https://github.com/svofski/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+LICENSE="Unlicense"
+SLOT="0"
+
+S="${WORKDIR}/${MY_PN}-${EGIT_COMMIT}"
+
+FONT_S="${S}"
+FONT_SUFFIX="ttf"
+
+src_configure() {
+ :;
+}
+
+src_compile() {
+ :;
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+
+ einfo "Since the GlassTTY VT220 font is fixed,"
+ einfo "you must use a font size of 15 for best quality."
+}