summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-28 22:38:54 +0000
committerSam James <sam@gentoo.org>2024-12-28 22:39:27 +0000
commit7dbd2d6d38f40a5c7fe844b6e539feb693e2195b (patch)
tree414adb5b532e6856027eeec00e768227f0f2a62f /mail-mta/postfix
parentgames-util/lgogdownloader: Version bump to 3.16, drop old 3.15-r1 (diff)
downloadgentoo-7dbd2d6d38f40a5c7fe844b6e539feb693e2195b.tar.gz
gentoo-7dbd2d6d38f40a5c7fe844b6e539feb693e2195b.tar.bz2
gentoo-7dbd2d6d38f40a5c7fe844b6e539feb693e2195b.zip
mail-mta/postfix: build w/ -std=gnu17
Reported upstream but they recommend using gnu17 for now. Closes: https://bugs.gentoo.org/945733 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-mta/postfix')
-rw-r--r--mail-mta/postfix/postfix-3.10_pre20241202.ebuild5
-rw-r--r--mail-mta/postfix/postfix-3.9.0-r2.ebuild5
-rw-r--r--mail-mta/postfix/postfix-3.9.1.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/mail-mta/postfix/postfix-3.10_pre20241202.ebuild b/mail-mta/postfix/postfix-3.10_pre20241202.ebuild
index f9aa172eb2af..dd2d17dc5128 100644
--- a/mail-mta/postfix/postfix-3.10_pre20241202.ebuild
+++ b/mail-mta/postfix/postfix-3.10_pre20241202.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit pam systemd toolchain-funcs
+inherit flag-o-matic pam systemd toolchain-funcs
MY_PV="${PV/_pre/-}"
MY_SRC="${PN}-${MY_PV}"
@@ -75,6 +75,9 @@ src_configure() {
# bug #915670
unset LD_LIBRARY_PATH
+ # https://marc.info/?l=postfix-users&m=173542420611213&w=2 (bug #945733)
+ append-cflags -std=gnu17
+
for name in CDB LDAP LMDB MONGODB MYSQL PCRE PGSQL SDBM SQLITE
do
local AUXLIBS_${name}=""
diff --git a/mail-mta/postfix/postfix-3.9.0-r2.ebuild b/mail-mta/postfix/postfix-3.9.0-r2.ebuild
index 3ce5bf31471f..99ca912a4e9b 100644
--- a/mail-mta/postfix/postfix-3.9.0-r2.ebuild
+++ b/mail-mta/postfix/postfix-3.9.0-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit pam systemd toolchain-funcs
+inherit flag-o-matic pam systemd toolchain-funcs
MY_PV="${PV/_pre/-}"
MY_SRC="${PN}-${MY_PV}"
@@ -79,6 +79,9 @@ src_configure() {
# bug #915670
unset LD_LIBRARY_PATH
+ # https://marc.info/?l=postfix-users&m=173542420611213&w=2 (bug #945733)
+ append-cflags -std=gnu17
+
for name in CDB LDAP LMDB MONGODB MYSQL PCRE PGSQL SDBM SQLITE
do
local AUXLIBS_${name}=""
diff --git a/mail-mta/postfix/postfix-3.9.1.ebuild b/mail-mta/postfix/postfix-3.9.1.ebuild
index 316613eea2d2..fe5e4330750f 100644
--- a/mail-mta/postfix/postfix-3.9.1.ebuild
+++ b/mail-mta/postfix/postfix-3.9.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit pam systemd toolchain-funcs
+inherit flag-o-matic pam systemd toolchain-funcs
MY_PV="${PV/_pre/-}"
MY_SRC="${PN}-${MY_PV}"
@@ -79,6 +79,9 @@ src_configure() {
# bug #915670
unset LD_LIBRARY_PATH
+ # https://marc.info/?l=postfix-users&m=173542420611213&w=2 (bug #945733)
+ append-cflags -std=gnu17
+
for name in CDB LDAP LMDB MONGODB MYSQL PCRE PGSQL SDBM SQLITE
do
local AUXLIBS_${name}=""