summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-24 19:12:27 +0000
committerSam James <sam@gentoo.org>2022-02-24 19:14:34 +0000
commitcceb79a51dd951143e0d3ec9d1ca1be158790637 (patch)
tree67eec104bc9ee6f891db632deb2477af145ddaea /mail-mta/notqmail
parentsys-apps/util-linux: stable 2.37.4 for hppa, bug #833367 (diff)
downloadgentoo-cceb79a51dd951143e0d3ec9d1ca1be158790637.tar.gz
gentoo-cceb79a51dd951143e0d3ec9d1ca1be158790637.tar.bz2
gentoo-cceb79a51dd951143e0d3ec9d1ca1be158790637.zip
mail-mta/notqmail: sync live, conditionally inherit verify-sig for non-live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-mta/notqmail')
-rw-r--r--mail-mta/notqmail/notqmail-1.08-r6.ebuild11
-rw-r--r--mail-mta/notqmail/notqmail-9999.ebuild26
2 files changed, 26 insertions, 11 deletions
diff --git a/mail-mta/notqmail/notqmail-1.08-r6.ebuild b/mail-mta/notqmail/notqmail-1.08-r6.ebuild
index 2150b53a5175..f8fec34a0f00 100644
--- a/mail-mta/notqmail/notqmail-1.08-r6.ebuild
+++ b/mail-mta/notqmail/notqmail-1.08-r6.ebuild
@@ -13,12 +13,13 @@ QMAIL_BIGTODO_F=notqmail-1.08-big-todo.patch
QMAIL_LARGE_DNS="qmail-103.patch"
-inherit qmail systemd verify-sig
+inherit qmail systemd
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/notqmail/notqmail.git"
inherit git-r3
else
+ inherit verify-sig
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
SRC_URI="
https://github.com/notqmail/notqmail/releases/download/${P}/${P}.tar.xz
@@ -63,13 +64,13 @@ VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/notqmail.asc
LICENSE="public-domain"
SLOT="0"
-IUSE="authcram gencertdaily highvolume pop3 qmail-spp ssl test vanilla verify-sig"
+IUSE="authcram gencertdaily highvolume pop3 qmail-spp ssl test vanilla"
REQUIRED_USE="vanilla? ( !ssl !qmail-spp !highvolume !authcram !gencertdaily ) gencertdaily? ( ssl )"
RESTRICT="!test? ( test )"
-BDEPEND="
- verify-sig? ( sec-keys/openpgp-keys-notqmail )
-"
+if [[ ${PV} != 9999 ]] ; then
+ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-notqmail )"
+fi
DEPEND="
net-dns/libidn2
net-mail/queue-repair
diff --git a/mail-mta/notqmail/notqmail-9999.ebuild b/mail-mta/notqmail/notqmail-9999.ebuild
index d622c556ab57..6ce036b2f82c 100644
--- a/mail-mta/notqmail/notqmail-9999.ebuild
+++ b/mail-mta/notqmail/notqmail-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,8 +17,14 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/notqmail/notqmail.git"
inherit git-r3
else
- KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
- SRC_URI="https://github.com/notqmail/notqmail/releases/download/${P}/${P}.tar.xz"
+ inherit verify-sig
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ SRC_URI="
+ https://github.com/notqmail/notqmail/releases/download/${P}/${P}.tar.xz
+ verify-sig? (
+ https://github.com/notqmail/notqmail/releases/download/${P}/${P}.tar.xz.sig
+ )
+ "
fi
DESCRIPTION="Collaborative open-source successor to qmail"
@@ -51,12 +57,17 @@ SRC_URI="${SRC_URI}
)
"
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/notqmail.asc
+
LICENSE="public-domain"
SLOT="0"
IUSE="authcram gencertdaily highvolume pop3 qmail-spp ssl test vanilla"
REQUIRED_USE="vanilla? ( !ssl !qmail-spp !highvolume !authcram !gencertdaily ) gencertdaily? ( ssl )"
RESTRICT="!test? ( test )"
+if [[ ${PV} != 9999 ]] ; then
+ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-notqmail )"
+fi
DEPEND="
net-dns/libidn2
net-mail/queue-repair
@@ -99,12 +110,15 @@ src_unpack() {
genqmail_src_unpack
[[ ${PV} == "9999" ]] && git-r3_src_unpack
- [[ ${PV} != "9999" ]] && default
+ if [[ ${PV} != "9999" ]]; then
+ default
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ fi
+ fi
}
src_prepare() {
- PATCHES=()
-
if ! use vanilla; then
if use qmail-spp; then
PATCHES+=( "${DISTDIR}/${P}-auth.patch" )