summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /lxqt-base/lxqt-panel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'lxqt-base/lxqt-panel')
-rw-r--r--lxqt-base/lxqt-panel/Manifest3
-rw-r--r--lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild66
-rw-r--r--lxqt-base/lxqt-panel/lxqt-panel-0.8.0.ebuild74
-rw-r--r--lxqt-base/lxqt-panel/lxqt-panel-0.9.0.ebuild76
-rw-r--r--lxqt-base/lxqt-panel/metadata.xml30
5 files changed, 249 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-panel/Manifest b/lxqt-base/lxqt-panel/Manifest
new file mode 100644
index 000000000000..2d887d2e06c8
--- /dev/null
+++ b/lxqt-base/lxqt-panel/Manifest
@@ -0,0 +1,3 @@
+DIST lxqt-panel-0.7.0.tar.xz 247640 SHA256 13fcdd33dfe1a691395765032dd6ae6eab5d4988ba96fb79b3d521e216383677 SHA512 e8817bc424c9c4369afd6f300d54f752cbb448767277eaa3024b44b0cb557e14721b19e83ba647fc1e0aac2923651782cd4964cf92a419f93b4f450351dcda28 WHIRLPOOL 5d29ab327eafe5a33a060e91b63d0320ae11000a2ec4bd58b9313a3eb0f6a78a7c5de1e7375de6c3bfe51f717d7998551d821b966a629263a4cfb873dc79e92b
+DIST lxqt-panel-0.8.0.tar.xz 259284 SHA256 5c453372bf6d35f09400788f6dece1403b63e7cf25abe62066fc9e82c5170b78 SHA512 ffa938586eccd743a676a8a0075a236b763bc3652c9a827c9906e83e87a926ba46a5577e047208b873fe6d53a5f39318aa7e3a1a1525ac89396bb63a52d5c09f WHIRLPOOL 8fa8da6635c423e111a7f37c7624ee0b30d78e5b1524bf78f371f4113a558cee6876f7463083b5c37111f5ec2f4a8079abb15590be0ae846521eb78cd9b39771
+DIST lxqt-panel-0.9.0.tar.xz 277840 SHA256 96b2c2f1b7de7605ac79f094936e6fcf8f0034342e11d84624a033f2450f6bf1 SHA512 f14922d0ea8b0258bcf6aba6ae4430d901002772c9f83a55cb9188b2c92dc440cb30170296326f1f22d49bec9b271e044da30b60e54a8d4483cd4bc358a8e81e WHIRLPOOL 6c94c7160111e03795f959d653bf8392cf934631c7bd849806df6c28080618db5c841c545d6bb97576e58981de8c476ea205bb7a3aea68813318dafb3d2a71bc
diff --git a/lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild b/lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..087737006bbd
--- /dev/null
+++ b/lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt desktop panel and plugins"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+IUSE="+alsa +clock colorpicker cpuload +desktopswitch dom +kbindicator +mainmenu
+ +mount networkmonitor pulseaudio +quicklaunch screensaver sensors
+ +showdesktop sysstat +taskbar teatime +tray +volume worldclock"
+REQUIRED_USE="volume? ( || ( alsa pulseaudio ) )"
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ >=lxde-base/menu-cache-0.3.3
+ ~lxqt-base/liblxqt-${PV}
+ ~lxqt-base/liblxqt-mount-${PV}
+ ~lxqt-base/lxqt-globalkeys-${PV}
+ ~dev-libs/libqtxdg-0.5.3
+ x11-libs/libX11
+ cpuload? ( sys-libs/libstatgrab )
+ networkmonitor? ( sys-libs/libstatgrab )
+ sensors? ( sys-apps/lm_sensors )
+ sysstat? ( ~lxqt-base/libsysstat-0.1.0 )
+ volume? ( alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio ) )
+ worldclock? ( dev-libs/icu:= )"
+RDEPEND="${DEPEND}
+ lxde-base/lxmenu-data"
+
+src_configure() {
+ local mycmakeargs i y
+ for i in clock colorpicker cpuload desktopswitch dom kbindicator mainmenu mount \
+ networkmonitor quicklaunch screensaver sensors showdesktop sysstat \
+ taskbar teatime tray volume worldclock; do
+ y=$(tr '[:lower:]' '[:upper:]' <<< "${i}")
+ mycmakeargs+=( $(cmake-utils_use ${i} ${y}_PLUGIN) )
+ done
+
+ if use volume; then
+ mycmakeargs+=( $(cmake-utils_use alsa VOLUME_USE_ALSA)
+ $(cmake-utils_use pulseaudio VOLUME_USE_PULSEAUDIO) )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install(){
+ cmake-utils_src_install
+ doman panel/man/*.1
+}
diff --git a/lxqt-base/lxqt-panel/lxqt-panel-0.8.0.ebuild b/lxqt-base/lxqt-panel/lxqt-panel-0.8.0.ebuild
new file mode 100644
index 000000000000..6016c88c0c98
--- /dev/null
+++ b/lxqt-base/lxqt-panel/lxqt-panel-0.8.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt desktop panel and plugins"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+IUSE="+alsa +clock colorpicker cpuload +desktopswitch dom +kbindicator +mainmenu
+ +mount networkmonitor pulseaudio +quicklaunch screensaver sensors
+ +showdesktop sysstat +taskbar teatime +tray +volume worldclock"
+REQUIRED_USE="volume? ( || ( alsa pulseaudio ) )"
+
+DEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ >=lxde-base/menu-cache-0.3.3
+ ~lxqt-base/liblxqt-${PV}
+ ~lxqt-base/liblxqt-mount-${PV}
+ ~lxqt-base/lxqt-globalkeys-${PV}
+ >=dev-libs/libqtxdg-1.0.0
+ x11-libs/libX11
+ cpuload? ( sys-libs/libstatgrab )
+ networkmonitor? ( sys-libs/libstatgrab )
+ sensors? ( sys-apps/lm_sensors )
+ sysstat? ( >=lxqt-base/libsysstat-0.2.0 )
+ volume? ( alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio ) )
+ worldclock? ( dev-libs/icu:= )"
+RDEPEND="${DEPEND}
+ >=lxde-base/lxmenu-data-0.1.2"
+
+src_configure() {
+ local mycmakeargs i y
+ for i in clock colorpicker cpuload desktopswitch dom kbindicator mainmenu mount \
+ networkmonitor quicklaunch screensaver sensors showdesktop sysstat \
+ taskbar teatime tray volume worldclock; do
+ y=$(tr '[:lower:]' '[:upper:]' <<< "${i}")
+ mycmakeargs+=( $(cmake-utils_use ${i} ${y}_PLUGIN) )
+ done
+
+ if use volume; then
+ mycmakeargs+=( $(cmake-utils_use alsa VOLUME_USE_ALSA)
+ $(cmake-utils_use pulseaudio VOLUME_USE_PULSEAUDIO) )
+ fi
+
+ mycmakeargs+=(
+ -DUSE_QT5=ON
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install(){
+ cmake-utils_src_install
+ doman panel/man/*.1
+}
diff --git a/lxqt-base/lxqt-panel/lxqt-panel-0.9.0.ebuild b/lxqt-base/lxqt-panel/lxqt-panel-0.9.0.ebuild
new file mode 100644
index 000000000000..4da8b2278a04
--- /dev/null
+++ b/lxqt-base/lxqt-panel/lxqt-panel-0.9.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt desktop panel and plugins"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+IUSE="+alsa +clock colorpicker cpuload +desktopswitch dom +kbindicator +mainmenu
+ +mount networkmonitor pulseaudio +quicklaunch screensaver sensors
+ +showdesktop sysstat +taskbar +tray +volume worldclock"
+REQUIRED_USE="volume? ( || ( alsa pulseaudio ) )"
+
+DEPEND="
+ dev-libs/glib:2
+ >=dev-libs/libqtxdg-1.0.0
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kguiaddons:5
+ kde-frameworks/kwindowsystem:5[X]
+ >=lxde-base/menu-cache-0.3.3
+ ~lxqt-base/liblxqt-${PV}
+ ~lxqt-base/liblxqt-mount-${PV}
+ ~lxqt-base/lxqt-globalkeys-${PV}
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXrender
+ cpuload? ( sys-libs/libstatgrab )
+ networkmonitor? ( sys-libs/libstatgrab )
+ sensors? ( sys-apps/lm_sensors )
+ sysstat? ( =lxqt-base/libsysstat-0.3* )
+ volume? ( alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio ) )"
+RDEPEND="${DEPEND}
+ dev-qt/qtsvg:5
+ >=lxde-base/lxmenu-data-0.1.2"
+
+src_configure() {
+ local mycmakeargs i y
+ for i in clock colorpicker cpuload desktopswitch dom kbindicator mainmenu mount \
+ networkmonitor quicklaunch screensaver sensors showdesktop sysstat \
+ taskbar tray volume worldclock; do
+ y=$(tr '[:lower:]' '[:upper:]' <<< "${i}")
+ mycmakeargs+=( $(cmake-utils_use ${i} ${y}_PLUGIN) )
+ done
+
+ if use volume; then
+ mycmakeargs+=( $(cmake-utils_use alsa VOLUME_USE_ALSA)
+ $(cmake-utils_use pulseaudio VOLUME_USE_PULSEAUDIO) )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install(){
+ cmake-utils_src_install
+ doman panel/man/*.1
+}
diff --git a/lxqt-base/lxqt-panel/metadata.xml b/lxqt-base/lxqt-panel/metadata.xml
new file mode 100644
index 000000000000..7948c162e913
--- /dev/null
+++ b/lxqt-base/lxqt-panel/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxqt</herd>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+ <use>
+ <flag name="clock">Build clock plugin</flag>
+ <flag name="colorpicker">Build colorpicker plugin</flag>
+ <flag name="cpuload">Build cpuload plugin</flag>
+ <flag name="desktopswitch">Build desktopswitch plugin</flag>
+ <flag name="dom">Build dom plugin</flag>
+ <flag name="kbindicator">Build kbindicator plugin</flag>
+ <flag name="mainmenu">Build mainmenu plugin</flag>
+ <flag name="mount">Build mount plugin</flag>
+ <flag name="networkmonitor">Build networkmonitor plugin</flag>
+ <flag name="quicklaunch">Build quicklaunch plugin</flag>
+ <flag name="screensaver">Build screensaver plugin</flag>
+ <flag name="sensors">Build sensors plugin</flag>
+ <flag name="showdesktop">Build showdesktop plugin</flag>
+ <flag name="sysstat">Build sysstat plugin</flag>
+ <flag name="taskbar">Build taskbar plugin</flag>
+ <flag name="teatime">Build teatime plugin</flag>
+ <flag name="tray">Build tray plugin</flag>
+ <flag name="volume">Build volume plugin</flag>
+ <flag name="worldclock">Build worldclock plugin</flag>
+ </use>
+</pkgmetadata>