summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-22 21:36:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-23 19:29:36 +0100
commit970a539ca88f58e9029d24a7a68312530c824a36 (patch)
tree4b32822a781910ab3ae31011a6bc7f0018786815 /kde-plasma
parentkde-plasma/kscreenlocker: 5.91.0 version bump (diff)
downloadgentoo-970a539ca88f58e9029d24a7a68312530c824a36.tar.gz
gentoo-970a539ca88f58e9029d24a7a68312530c824a36.tar.bz2
gentoo-970a539ca88f58e9029d24a7a68312530c824a36.zip
kde-plasma/ksshaskpass: 5.91.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.91.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 3012d10efdbf..69f74d42287f 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.27.10.tar.xz 28044 BLAKE2B ba716a154ec0946d5e6b2dc340ce7c3dc8f84fdae52956661a4cd8aa142a977fd26bf99ea060f3834819b887ede03dca5d7d4112509384b3c1437709510e8076 SHA512 4e868547493904c79d37a9170e8d3fbce9e47ea762ae8c59507faab9517478b44cbb48cd2fa6c8bd9f9e41f74e57a859e127db258be2b7a643c6b68fecec4a31
DIST ksshaskpass-5.27.9.tar.xz 28032 BLAKE2B 3e120fd3bde294ea183e6531a6c6dff5140f2374dcc648b34255845e3d63577996f884405d769166da14e93e4ae9c515afb031a35615549bdf2ca68e727a2c1b SHA512 37032f6580d5f3f2d1b10a94c8abd83dd7a79c2920730b8f18a801706d7920e186d56d7edf7a62256c589792dd33e26f185c79c121acf0d27ee6585a474c34de
+DIST ksshaskpass-5.91.0.tar.xz 28864 BLAKE2B 5d7959a1c3bb2bdd4c791b0fceeb9d9ac783dbe296a0d50912b6a5205f30190d8ee73072e6323828297edb1244c4dab302a655e9782276088fa2ab39cd3bf007 SHA512 4d82f683ce5e979f3b2d4a51534664fbeb68e092333e622ae69268d8c618e71a90b183d24a38ba2b597308deaae535d5b64651e42ca35636b74d3f12724df79d
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.91.0.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.91.0.ebuild
new file mode 100644
index 000000000000..3a195dbe83a3
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.91.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.247.0
+QTMIN=6.6.0
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 6,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 6 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+}