summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-18 14:05:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-18 15:46:37 +0200
commit5ac195cead064441ea287b6e8fa6faaee0956f77 (patch)
tree7f82899bf07c216c68567722c1ec2577d976df27 /kde-plasma
parentkde-plasma/khotkeys: 5.26.1 version bump (diff)
downloadgentoo-5ac195cead064441ea287b6e8fa6faaee0956f77.tar.gz
gentoo-5ac195cead064441ea287b6e8fa6faaee0956f77.tar.bz2
gentoo-5ac195cead064441ea287b6e8fa6faaee0956f77.zip
kde-plasma/kinfocenter: 5.26.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.26.1.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index fa49d1fdbf2d..a39ee32c58a3 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.25.5.tar.xz 730600 BLAKE2B ab94fb984cbdb4827a3e06a15e1d3dcc4510be7db3f40bd8124c469bddf461fc2b36311e1e4be57cfd9d6ea5fcdf34be006b73f810efa55bd00ef9299531be3a SHA512 9683cac383d52871a37a4847cb416384d241a5fcd1a2c69be6992c77504453718fd8b0235195008872a3983033d4f63ec2748cd00cdeee6fcf270d054ac6e21c
DIST kinfocenter-5.26.0.tar.xz 729728 BLAKE2B c8d23138676bc7f5a86b5c423dbefd13f6e0b7762a7ea36c062272bc8f9f281ddaff251ba1a7dadd26110eaba6d057e9026100a7afe832e1f135707e36bec49c SHA512 1d83464babaf26a00c50cd28f4e8b4ba56bc6a53a103612b3e1d286571a633ed4196f58ed19b07f8011e2dcf435c78461846e4ffd97a4ac6ee453ded0bc0df9e
+DIST kinfocenter-5.26.1.tar.xz 729392 BLAKE2B 58eef1f8bf49ce4bed28092054794aae39990166a06534f86dfcb3d71df0b42f6be67d874db4c8d5b291f1aa35f815af08d3ba633e87e9a67c53badf74b10743 SHA512 43338a340b587eccb152ba68136ce7ea6c8c9dbf87c45bfa34c38615bbfccdf1fb0c62b4712cf963a3604ff98b34b8f4bcb774dbdd2820199d88688cd03275d8
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.26.1.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.26.1.ebuild
new file mode 100644
index 000000000000..197869ea88d1
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.26.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.99.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.5
+inherit ecm plasma.kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ gles2-only? ( media-libs/mesa[gles2] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+ >=kde-plasma/systemsettings-${PVCUT}:5
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:5"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ fi
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ ecm_pkg_postinst
+}