summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-12 22:38:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-12 22:41:48 +0200
commitd8329f9c951ac31c93d32b3af9de2c1221b33354 (patch)
treec577cc92de751ea8a28e2b5b952a3357f2a665d9 /kde-plasma/kwin
parentnet-im/centerim: remove .la files, bug #848750 (diff)
downloadgentoo-d8329f9c951ac31c93d32b3af9de2c1221b33354.tar.gz
gentoo-d8329f9c951ac31c93d32b3af9de2c1221b33354.tar.bz2
gentoo-d8329f9c951ac31c93d32b3af9de2c1221b33354.zip
kde-plasma/kwin: Fix cursor position snap back regression in games
Revert "wayland: Avoid pointer warp if constraint region is invalid" KDE-bug: https://bugs.kde.org/show_bug.cgi?id=469555 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwin')
-rw-r--r--kde-plasma/kwin/files/kwin-5.27.5-revert-7c91c4ba.patch49
-rw-r--r--kde-plasma/kwin/kwin-5.27.5-r2.ebuild144
2 files changed, 193 insertions, 0 deletions
diff --git a/kde-plasma/kwin/files/kwin-5.27.5-revert-7c91c4ba.patch b/kde-plasma/kwin/files/kwin-5.27.5-revert-7c91c4ba.patch
new file mode 100644
index 000000000000..f7c2047818b3
--- /dev/null
+++ b/kde-plasma/kwin/files/kwin-5.27.5-revert-7c91c4ba.patch
@@ -0,0 +1,49 @@
+From 3d62e7548955e2ddf298c61a55fcd26007ea27bb Mon Sep 17 00:00:00 2001
+From: Vlad Zahorodnii <vlad.zahorodnii@kde.org>
+Date: Thu, 11 May 2023 22:56:32 +0300
+Subject: [PATCH] Revert "wayland: Avoid pointer warp if constraint region is
+ invalid"
+
+This reverts commit 7c91c4bad9ee709eebfdf9d5b3997fa00ca7cd13.
+
+It created regressions in some video games. After a closer look at the
+pointer constraint region handling, there are some issues, but it might
+be safer to fix them in master.
+
+In meanwhile, let's revert 7c91c4bad because it breaks more things than
+it fixes.
+
+CCBUG: 457021
+BUG: 469555
+
+
+(cherry picked from commit 07da1796b8388b00275d8281fac476bde71cd02b)
+---
+ src/pointer_input.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/pointer_input.cpp b/src/pointer_input.cpp
+index 2b582649a61..d47b5bc47d3 100644
+--- a/src/pointer_input.cpp
++++ b/src/pointer_input.cpp
+@@ -669,7 +669,7 @@ void PointerInputRedirection::updatePointerConstraints()
+ lock->setLocked(false);
+ m_locked = false;
+ disconnectLockedPointerAboutToBeUnboundConnection();
+- if (!(hint.x() < 0 || hint.y() < 0 || !lock->region().contains(hint.toPoint())) && focus()) {
++ if (!(hint.x() < 0 || hint.y() < 0) && focus()) {
+ processMotionAbsolute(focus()->mapFromLocal(hint), waylandServer()->seat()->timestamp());
+ }
+ }
+@@ -684,7 +684,7 @@ void PointerInputRedirection::updatePointerConstraints()
+ // In this case the cached cursor position hint must be fetched before the resource goes away
+ m_lockedPointerAboutToBeUnboundConnection = connect(lock, &KWaylandServer::LockedPointerV1Interface::aboutToBeDestroyed, this, [this, lock]() {
+ const auto hint = lock->cursorPositionHint();
+- if (hint.x() < 0 || hint.y() < 0 || !lock->region().contains(hint.toPoint()) || !focus()) {
++ if (hint.x() < 0 || hint.y() < 0 || !focus()) {
+ return;
+ }
+ auto globalHint = focus()->mapFromLocal(hint);
+--
+GitLab
+
diff --git a/kde-plasma/kwin/kwin-5.27.5-r2.ebuild b/kde-plasma/kwin/kwin-5.27.5-r2.ebuild
new file mode 100644
index 000000000000..8b3d63a473fd
--- /dev/null
+++ b/kde-plasma/kwin/kwin-5.27.5-r2.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+ECM_TEST="optional"
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.7
+VIRTUALX_REQUIRED="test"
+inherit ecm plasma.kde.org optfeature
+
+DESCRIPTION="Flexible, composited Window Manager for windowing systems on Linux"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="accessibility caps gles2-only lock multimedia plasma screencast"
+
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=dev-libs/libinput-1.19
+ >=dev-libs/wayland-1.21.0
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[egl,gles2-only=,libinput]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5[qml]
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5=[X]
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kidletime-${KFMIN}:5=
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=[X]
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ >=kde-plasma/kdecoration-${PVCUT}:5
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/lcms:2
+ media-libs/libepoxy
+ media-libs/libglvnd
+ >=media-libs/mesa-21.3[egl(+),gbm(+),wayland,X]
+ virtual/libudev:=
+ x11-libs/libX11
+ x11-libs/libXi
+ >=x11-libs/libdrm-2.4.112
+ >=x11-libs/libxcb-1.10
+ >=x11-libs/libxcvt-0.1.1
+ >=x11-libs/libxkbcommon-1.5.0
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ accessibility? ( media-libs/libqaccessibilityclient:5 )
+ caps? ( sys-libs/libcap )
+ gles2-only? ( media-libs/mesa[gles2] )
+ lock? ( >=kde-plasma/kscreenlocker-${PVCUT}:5 )
+ plasma? ( >=kde-frameworks/krunner-${KFMIN}:5 )
+ screencast? ( >=media-video/pipewire-0.3:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-plasma/kwayland-server
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtvirtualkeyboard-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5[qml]
+ sys-apps/hwdata
+ x11-base/xwayland
+ multimedia? ( >=dev-qt/qtmultimedia-${QTMIN}:5[gstreamer,qml] )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.9
+ >=dev-libs/wayland-protocols-1.31
+ >=dev-qt/designer-${QTMIN}:5
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ x11-base/xorg-proto
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+"
+PDEPEND=">=kde-plasma/kde-cli-tools-${PVCUT}:5"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-xcbutils-nativeFloor.patch" #KDE-bug 459373
+ "${FILESDIR}/${P}-revert-7c91c4ba.patch" #KDE-bug 469555
+)
+
+src_prepare() {
+ ecm_src_prepare
+ use multimedia || eapply "${FILESDIR}/${PN}-5.26.80-gstreamer-optional.patch"
+
+ # TODO: try to get a build switch upstreamed
+ if ! use screencast; then
+ sed -e "s/^pkg_check_modules.*PipeWire/#&/" -i CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # KWIN_BUILD_NOTIFICATIONS exists, but kdeclarative still hard-depends on it
+ $(cmake_use_find_package accessibility QAccessibilityClient)
+ $(cmake_use_find_package caps Libcap)
+ -DKWIN_BUILD_SCREENLOCKER=$(usex lock)
+ $(cmake_use_find_package plasma KF5Runner)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ optfeature "color management support" x11-misc/colord
+ elog
+ elog "In Plasma 5.20, default behavior of the Task Switcher to move minimised"
+ elog "windows to the end of the list was changed so that it remains in the"
+ elog "original order. To revert to the well established behavior:"
+ elog
+ elog " - Edit ~/.config/kwinrc"
+ elog " - Find [TabBox] section"
+ elog " - Add \"MoveMinimizedWindowsToEndOfTabBoxFocusChain=true\""
+}