summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-29 19:11:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-29 19:57:58 +0100
commita6b537bea3e38dadba52f5e69d6e2d2af3bcbfbe (patch)
tree5fed4661d8d049e626713680c4c0ce55a3bb3ff7 /kde-plasma/kwayland-integration
parentkde-plasma/kwallet-pam: 5.26.4 version bump (diff)
downloadgentoo-a6b537bea3e38dadba52f5e69d6e2d2af3bcbfbe.tar.gz
gentoo-a6b537bea3e38dadba52f5e69d6e2d2af3bcbfbe.tar.bz2
gentoo-a6b537bea3e38dadba52f5e69d6e2d2af3bcbfbe.zip
kde-plasma/kwayland-integration: 5.26.4 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.26.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index a2d3e9baba39..37fa365a9397 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-integration-5.25.5.tar.xz 24296 BLAKE2B 30fd0d0c2cb8ce34da692a40d558e7616796475f74ff7fc4212fdded88e7c55271836f160b48907fd3e195f41738c294e40c122bf51ec967861e17bc3d7de3bd SHA512 eabb2040275fd32b4ca1e8a5717a05589a331aac97e21861f36e8ac2b3c683b369d5f40507b0dbebd714dc766d311bd1233043327253e3c5d68de2464e12a342
DIST kwayland-integration-5.26.3.tar.xz 26944 BLAKE2B 4de0075c585f1e7596bc8ce61653139887090dfade4641d6f577fce3e48a5e6f191e7b52807dc38656f9d6f5a7878c09fe9d9a853bc35d9d0e42bb418b278099 SHA512 3fccb2133cc5c68e93c1c0f68f51cc440f138a8a2c5a05dc4b0cc642bb3efc6549433f07eab56c11ecc3439f69e6a777ac1fa9adb53164b424764b3f230d6ea4
+DIST kwayland-integration-5.26.4.tar.xz 26976 BLAKE2B 8d4afb514c6851255f437360a8240d95d9d2c5d51c3ada30bf1a8c30bda1a063e89e098509bc69e8226d7bfb18185221b909081982eab1d8ed2b80c9c84cce47 SHA512 59cf5dcdc8713654221ac5411885be5b656bf1d1cefd344f35b1a3f45e2f036a43633eb474bcc4357783e4e5114afee6c192c63e4c02325d8db9b329b460f1e3
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.26.4.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.26.4.ebuild
new file mode 100644
index 000000000000..528079dd6f10
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.26.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.99.0
+QTMIN=5.15.5
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module IdleTime
+ cmake_comment_add_subdirectory autotests # only contains idletime test
+ cmake_run_in src cmake_comment_add_subdirectory idletime
+}