summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-23 12:16:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-23 18:46:25 +0200
commit04b7a5abc61721150cbdaefb391c4365903d11a1 (patch)
tree17167a551e6bc11df15961a74f7e0e1dbbb04cf6 /kde-plasma/kwallet-pam
parentapp-crypt/argon2: Use optimized code on x86 only (diff)
downloadgentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.tar.gz
gentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.tar.bz2
gentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.zip
kde-plasma: KDE Plasma 5.17.1 version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.17.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index a09a0caa054d..c4f986b48483 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1 +1,2 @@
DIST kwallet-pam-5.16.5.tar.xz 19512 BLAKE2B dc053b8b02d44a3b94fe16d50b03bf91718392bdce60e69b956e5a84406012b567f4216b08b4d05c215cfa0e9e16c7537b60420a80bf501402a7cf302b853d9b SHA512 6a3c09b645a193bd5164525c6ca0c807a0adc141566db7436101784fef8def79e121c599a837dac32393f8e5ab2c33a9473a29013d07bd64e6a8eab32308d3d1
+DIST kwallet-pam-5.17.1.tar.xz 19716 BLAKE2B 7b70aa2afab3f2db210cd3a95659feeb75dcf4e1af647adfb20585e74011443622d3031c959825104a596721d657da89cbdb85dc8fcf3b72151724f6f288d7a0 SHA512 63867da87e4a1003a6709af47460936e538341b0f7272570ec741869b9cfc9c1ebfaf765c74149375233ae30c8c8352f44410f5348a21b8777208e5bf51bbae1
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.17.1.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.17.1.ebuild
new file mode 100644
index 000000000000..3b8009a01722
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.17.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kwallet)
+ dev-libs/libgcrypt:0=
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}