summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 10:58:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 11:07:37 +0200
commit03b5070fa51fa15ac47489fae77811eaa07e1b91 (patch)
tree891706a5e6725e4f37f331422302e6d53a82aa6a /kde-plasma/ksysguard
parentwww-apps/mediawiki: fixed test in postupgrade file (diff)
downloadgentoo-03b5070fa51fa15ac47489fae77811eaa07e1b91.tar.gz
gentoo-03b5070fa51fa15ac47489fae77811eaa07e1b91.tar.bz2
gentoo-03b5070fa51fa15ac47489fae77811eaa07e1b91.zip
kde-plasma: Add KDE Plasma 5.16.0
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest1
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.16.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index fe03d6684851..d1ee1bb823a9 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1 +1,2 @@
DIST ksysguard-5.15.5.tar.xz 500116 BLAKE2B 1a22e419af79685e241265d392eed7502998df88168adc4292c8500a152a8d1142d56c4a34dee409b29745d8a07f889c241b3ab9ab8f09f3eec68d1ec5826c79 SHA512 ae74adac0a4b20d9ddcf9b172542a3c96de46adb66b2f6c1d4e5f97562572e365f777d1daffd82e677ca1be37e868425112f69bd6e85e51118dc557f66ab5b8e
+DIST ksysguard-5.16.0.tar.xz 500380 BLAKE2B c69862d6a8192e5f9896037ba7bc969e236fdf53b19ba49da0bafa540c7434ad3bc23aacce494e43e76e989b22a3345d12bddb202542566135932ec707d60dbc SHA512 460cb3834654489aa3ca5a4863d06d3cbb18dbebb9bf452ca021e4bf06f8548e298101928e8e6e112dd179d32f52aa9bd948776edcf6169764e295006919f4eb
diff --git a/kde-plasma/ksysguard/ksysguard-5.16.0.ebuild b/kde-plasma/ksysguard/ksysguard-5.16.0.ebuild
new file mode 100644
index 000000000000..dc21acd63e69
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.16.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}