summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-14 20:39:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-14 21:13:51 +0100
commit1f4665f8b7919e545456c2c3c87d73be1dec331d (patch)
tree622c886cc2d8d9b0387fcc60634effb03d6035f8 /kde-plasma/kinfocenter
parentkde-plasma/khotkeys: 5.27.3 version bump (diff)
downloadgentoo-1f4665f8b7919e545456c2c3c87d73be1dec331d.tar.gz
gentoo-1f4665f8b7919e545456c2c3c87d73be1dec331d.tar.bz2
gentoo-1f4665f8b7919e545456c2c3c87d73be1dec331d.zip
kde-plasma/kinfocenter: 5.27.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.27.3.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index cf987aab059c..fe31ab6f0dc8 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.26.5.tar.xz 736144 BLAKE2B 1e6f6bc3abc78c1cfc6564b48fb9101158965b3aba029bd138d5f885163ebbaafaf6386c3a759ef67d8007844d1cc07a4c7191cc179b175ef99ca3f1e21fa8b1 SHA512 a00f71bbf7436bb5807f83060ab697b53a93b66f0e3a7ca6e791a45da8d468fc1616b991fc50292dd911ff6a66093e73b9216f8f28fe1434388e4d86c873537c
DIST kinfocenter-5.27.2.tar.xz 1015472 BLAKE2B df5f212897cf0a4389a4170a68712460e4f8fea1067a69820c1f94d9d6ada71204ac02b7246fc5b74f5837649d60840e9efd6055d9b0efbcbe4f372f735690c0 SHA512 b89935c7744a0c1e20b4cc4d25a2a18148afea0b61962129fcc4917f34abb36bcda39fe830c68219be54fedec4af2a9cc160f375271b31d57c6d4b2628c52106
+DIST kinfocenter-5.27.3.tar.xz 1015740 BLAKE2B 618494b61a4e360e6ef8a43285a31957d1f80927c25814ab0408a57afdbd5838ecf8f5bda7f4c2fcfa6dc3d48adf3250a0e019aaf81fcf604e1df73d2b63fbb2 SHA512 46d3b452bf85c9734a17032d5c0724a237d02dd8505abf8b6c1ac1a0c1ca7dd332be61e9cdcac425ad65f0c0924516b6bbcbbed63f5928f278f854e56a0be16e
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.27.3.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.27.3.ebuild
new file mode 100644
index 000000000000..9771a9a251ac
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.27.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.7
+inherit ecm plasma.kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ gles2-only? ( media-libs/mesa[gles2] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qdbus:*
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+ >=kde-plasma/systemsettings-${PVCUT}:5
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:5"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ fi
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ ecm_pkg_postinst
+}