summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-23 12:16:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-23 18:46:25 +0200
commit04b7a5abc61721150cbdaefb391c4365903d11a1 (patch)
tree17167a551e6bc11df15961a74f7e0e1dbbb04cf6 /kde-plasma/drkonqi
parentapp-crypt/argon2: Use optimized code on x86 only (diff)
downloadgentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.tar.gz
gentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.tar.bz2
gentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.zip
kde-plasma: KDE Plasma 5.17.1 version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/drkonqi')
-rw-r--r--kde-plasma/drkonqi/Manifest1
-rw-r--r--kde-plasma/drkonqi/drkonqi-5.17.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/kde-plasma/drkonqi/Manifest b/kde-plasma/drkonqi/Manifest
index c3f4511da351..3e1de70d9457 100644
--- a/kde-plasma/drkonqi/Manifest
+++ b/kde-plasma/drkonqi/Manifest
@@ -1 +1,2 @@
DIST drkonqi-5.16.5.tar.xz 743220 BLAKE2B d878bcde06693b309be7ed9b8f6a9de952f41c00701fe4a4b84df7a557e8b0e996a9f37402c1d8f10363822220deccf71416412895336abee4acc77fef6c5610 SHA512 4d42e69301e4af88c292d6072055384ebf79b91240504c23f393abba9f7def5b15da9f252efa76232535ce6bdfe77238131c88b98f89afdc38a7a107e7dc8c40
+DIST drkonqi-5.17.1.tar.xz 739860 BLAKE2B b45cdc73377337587035b44d0781e1ee3326679d4c1407b53a157160fc27f84694efe4085651a036d6efc3d273d82f055901567dc8a8544b4aa8b13deea392a5 SHA512 7772c48a4bda5b99b8f735bd4a96a8ae5518b455bc70cc572c7d681d6b5b67181bddf0a74c125d2c8f9c379b3f5e7f42c7be06b3e9b753538b5e538490576e47
diff --git a/kde-plasma/drkonqi/drkonqi-5.17.1.ebuild b/kde-plasma/drkonqi/drkonqi-5.17.1.ebuild
new file mode 100644
index 000000000000..8dbc6989fc44
--- /dev/null
+++ b/kde-plasma/drkonqi/drkonqi-5.17.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Plasma crash handler, gives the user feedback if a program crashed"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="X"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlrpcclient)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ X? ( $(add_qt_dep qtx11extras) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep qtconcurrent)
+"
+RDEPEND="${COMMON_DEPEND}
+ !<kde-plasma/plasma-workspace-5.10.95:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X Qt5X11Extras)
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ if ! has_version "sys-devel/gdb"; then
+ elog "For more usability consider installing the following package:"
+ elog " sys-devel/gdb - Easier debugging support"
+ fi
+}