summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-10-19 16:27:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-10-19 17:10:32 +0200
commit8423700c215f3f35de58f0fd00c10d2608308f95 (patch)
tree68c9bab52abfde64ddc476874b547ee9c96b01cb /kde-frameworks/frameworkintegration
parentapp-misc/when: Stabilize 1.1.45 ALLARCHES, #915994 (diff)
downloadgentoo-8423700c215f3f35de58f0fd00c10d2608308f95.tar.gz
gentoo-8423700c215f3f35de58f0fd00c10d2608308f95.tar.bz2
gentoo-8423700c215f3f35de58f0fd00c10d2608308f95.zip
kde-frameworks/frameworkintegration: 5.111.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.111.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index dcbab62a81aa..3d0737cd9a79 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1 +1,2 @@
DIST frameworkintegration-5.110.0.tar.xz 1760436 BLAKE2B 724ac1457276720c1aa7a02a02768f31d2fb3ec5cc7d0d216a4408735e89b1a49ee10e650e603bf12539456df77f309cd00bf6235542ef07302c93b87de63c47 SHA512 4571485b1ff815b8cca2a12d19cd103210471647de4b5971fdd866fe08ec7e0f6b5b36c43dcb062bc2234d7c6901d279b25eac7a44e5188e0ee4fe9a646b79db
+DIST frameworkintegration-5.111.0.tar.xz 1760432 BLAKE2B 9d81140f4f11c9cb496f68d1d04523892107465e3ac9bc63d84b7c773497436deda58d6bff50b9e30f88693f0d4a90973397081a00f57e5f6556fbb1b4f37d73 SHA512 8fa04ab6f88753ec75eb68868ab68ea14c2b8b31515438613b1843201ad82f789171d3f5e03b72a84e1ba9e729e113e5036f2f3861d69ffa92fc058b431687df
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.111.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.111.0.ebuild
new file mode 100644
index 000000000000..36b3122c1d84
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.111.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}